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Woord vooraf

Voor u ligt de zesde druk van de Handleiding Maple (geschreven met versie 15 en 16).
Het computeralgebrasysteem Maple ligt aan de basis van vele toepassingen die ervan zijn
afgeleid. Denk aan MapleSim, een simulatieprogramma voor industriële toepassingen of
denk aan Maple T.A. (testing and assessment) ten behoeve van geavanceerd digitaal toetsen.
Maple ondersteunt verder nog meer toepassingen. Als zelfstandig programma kan het
in feite beschouwd worden als een geavanceerde tekstverwerker met ondersteuning van
computeralgebra, reuze handig om rapporten te maken die er presentabel moeten uitzien,
waaronder de gehele achterliggende berekening beschikbaar blijft.

Er is in de tijd die verstreken is, sinds de eerste druk in 1993, enorm veel verbeterd aan het
programma wat betreft de gebruiksvriendelijkheid en de toevoeging van de vele tools ten
behoeve van de interface. Voor het eerst is deze handleiding nu niet meer gebaseerd op het
programma als Classic Worksheet, maar wordt de standaard interface gebruikt, die vooral de
laatste jaren fors verbeterd is en nu als volwassen beschouwd en zelfs met recht geavanceerd
genoemd mag worden. Dat brengt met zich mee dat daaraan in deze handleiding nogal wat
aandacht besteed moet worden ten koste van interessante wiskundige voorbeelden.

De ervaring leert dat zonder begeleiding de eerste kennismaking met het programma niet
tot het gewenste resultaat leidt. Het eerste hoofdstuk is lastig, maar beslist nodig om deze
drempel te nemen en van belang om de rest van het boek probleemloos te kunnen doorwerken
om vandaaruit uw eigen richting te kiezen. We beginnen dit hoofdstuk dan ook voorzichtig
met kleine voorbeelden van enkele berekeningen in een worksheet (werkblad), waarbij we er
steeds voor zorgen de volledige controle te hebben over het programma.

Gaandeweg wordt aandacht besteed aan de tekstverwerking binnen het programma waardoor
het worksheet kan uitgroeien tot een document, waarin u kunt rekenen en dat u kunt
gebruiken voor presentaties en verschijnen in drukvorm. Digitaal blijft het worksheet steeds
aan te passen en de berekeningen kunnen steeds opnieuw gedaan worden.

Om het verlies van interessante voorbeelden te compenseren is er een ondersteunende website
met legio uitgewerkte opgaven voor handen, waaronder in ieder geval de worksheets van de
eenvoudig gehouden voorbeelden in deze handleiding, geschikt voor HBO en Universiteit.

Er is ruimschoots aandacht besteed aan het syntax-vrij werken met het programma. Dat
houdt in dat u niet echt met de commando’s hoeft te werken als u af en toe eens iets met
het programma wilt doen. Wel wordt uitgebreid aandacht besteed aan de uitleg van de
commando’s om ze in de syntax-vrije situatie te kunnen aanpassen en eventueel uitbreiden en
ook te kunnen inzetten bijvoorbeeld bij het maken van toetsitems in Maple T.A.. Grafieken
krijgen ook een grote plaats in dit boek vanwege het belang van visualisaties bij rapportage
en verslaglegging, ter ondersteuning van onderzoek, het verlevendigen van toetsitems en het
gebruik bij feedback daarin.

In hoofdstuk 4 wordt een overzicht gegeven van de verschillende wiskundige objecten die
in de handleiding voorkomen. Dit is gedaan om het objectgeoriënteerde programma beter te
begrijpen en bovendien heeft het te maken met de context-menu’s die aangeboden worden
bij het gebruik van de rechtermuisknop. Het programma herkent namelijk het object dat
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aangeklikt wordt en biedt een bijpassend context-menu aan voor elementaire berekeningen
en bewerkingen.

U kunt ook knoppen en regelaars aan het document toevoegen ten behoeve van digitaal
gebruik. Dit komt in Hoofdstuk 7 aan de orde, evenals het maken van een presentabel
document waar codes onzichtbaar op de achtergrond werken.

Deze handleiding is ook te bebruiken voor eerdere versies van Maple en zeker ook voor
toekomstige versies als het gaat om het inzicht in de structuur en de commando’s in
verschillende situtaties. Zaken die gaan over de interface zullen misschien verschillen in
oudere versies. In ieder geval zorgt MapleSoft er wel voor dat de worksheets en documenten
in verschillende versies geopend en bewerkt kunnen worden, zoals dat tot nu toe steeds goed
geregeld is.

Hoewel het boek het beste lineair is door te werken, kan de gebruiker met behulp van de
inhoudsopgave en de uitgebreide index gemakkelijk iets van zijn gading vinden. Met de vele
verwijzingen hoeft niet per se de volgorde van het boek aangehouden te worden om toch snel
het niveau te bereiken van een handige gebruiker.

Veel succes met het gebruik van deze handleiding.

Metha Kamminga-van Hulsen
www.methakamminga.nl
Leeuwarden, december 2011
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2.1.1 Reële deel en imaginaire deel 36
2.1.2 Andere naam voor de imaginaire eenheid 37



viii Handleiding Maple 16

2.1.3 Basisbewerkingen en complex geconjugeerde 39
2.2 Standaardfuncties 40

2.2.1 Absolutewaardefuncties en wortelfuncties 41
2.2.2 Goniometrische en cyclometrische functies 42
2.2.3 Complexe getallen, modulus en argument 43
2.2.4 De exponentiële functie en de logaritmische functie 45
2.2.5 De formule van Euler 46
2.2.6 Oneigenlijke machten 47
2.2.7 Faculteitfunctie en binomiaalfunctie 48
2.2.8 Functienotatie 48
2.2.9 Samengestelde functies 51

2.3 Substitutie 52
2.3.1 Evaluatie van een formule met eval 52
2.3.2 Substitutie met subs en algsubs 54
2.3.3 Verschil tussen eval en subs 55
2.3.4 Herleiden met gebruik van vergelijkingen 56

2.4 Formulemanipulatie 57
2.4.1 Haakjes wegwerken (expand) 57
2.4.2 Ontbinden in factoren (factor) 58
2.4.3 Priemfactoren 59
2.4.4 GGD en KGV 60
2.4.5 Wortelvormen 60
2.4.6 Sorteren (sort) 61
2.4.7 Samennemen (collect) 62
2.4.8 Combineren (combine) 63
2.4.9 Kwadraatafsplitsen 64
2.4.10 Discriminant 65

2.5 Breuken 66
2.5.1 Teller en noemer van een breuk 66
2.5.2 Breuken optellen en vereenvoudigen 67
2.5.3 Breuksplitsen 67

2.6 Vergelijkingen en ongelijkheden 69
2.6.1 Exact oplossen (solve) 70
2.6.2 Vergelijkingen met parameters 72
2.6.3 Vrijmaken (isolate) 72
2.6.4 Numeriek oplossen (fsolve) 73
2.6.5 Oplossen in de reële getallen 75
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1 Snel aan de slag

1.1 Inleiding

Een computeralgebrasysteem is een krachtige rekenmachine die naast het gewone rekenen
met getallen ook symbolisch en algebraı̈sch kan rekenen.
Bovendien hebben computeralgebrasystemen uitgebreide grafische mogelijkheden.
Onder symbolisch rekenen verstaan we het rekenen met andere objecten dan getallen,
bijvoorbeeld met veeltermen, functies, rijen en vectoren. Algebraı̈sch rekenen wil zeggen,
niet afgerond rekenen; dit in tegenstelling tot wat er in numerieke programma’s gebeurt.
De berekeningen waaraan we hier denken, zijn bijvoorbeeld: differentiëren, integreren, het
oplossen van stelsels vergelijkingen, enzovoort.
Het computeralgebrasysteem kan heel goed interactief gebruikt worden; de gebruiker geeft
een opdracht, het computeralgebrasysteem voert de berekeningen uit en aan de hand van de
uitkomst van de berekening besluit de gebruiker tot een nieuwe opdracht.
Samenvattend kunnen we dus zeggen dat een computeralgebrasysteem een interactief
programma is ten behoeve van symbolische en algebraı̈sche wiskundige berekeningen.
Maple is zo’n systeem waarbij de grafische mogelijkheden bijzonder groot zijn. Bovendien
zijn de numerieke mogelijkheden in de laatste versies van het programma enorm uitgebreid
en doen nauwelijks onder voor specifiek numerieke programmatuur.
Rond 1980 begon men aan de Universiteit van Waterloo in Canada aan de ontwikkeling van
Maple en dit programma is momenteel uitgegroeid tot één van de grootste computeralgebra-
systemen. Het is zelfs mogelijk documenten te maken met berekeningen, tekst, formules,
grafieken en nog veel meer; namelijk documenten met buttons, sliders en andere interactieve
componenten. Dat alles komt aan de orde in hoofdstuk 7.

1.2 Een eerste Worksheet openen

We beginnen eerst eenvoudig met het openen van een leeg worksheet in de standaard
interface.
Kies bij het starten van het programma voor Maple 16. Grote kans dat dan een leeg blad
tevoorschijn komt waar de cursor bovenaan staat te knipperen en als u dan iets invult, zal dat
een opdracht of een formule moeten zijn, want meestal staat standaard de formule-editor aan
bij het begin. In deze handleiding zal voornamelijk gewerkt worden met de Worksheet Mode
en in eerste instantie nog niet met de Document Mode van het programma, dat komt pas in
hoofdstuk 7 aan de orde en daarvoor moet veel meer kennis van zaken aanwezig zijn om
het programma in deze Document Mode goed te kunnen bedienen. Het gaat er om dat we de
werking van Maple leren kennen en dat alles zo transparant en reproduceerbaar mogelijk is.
Dus eerst het programma openen in de standaard interface. Meestal is bij de installatie een
icoon op het bureaublad geplaatst en anders met Start→Programma’s naar Maple16. Het is
nogal belangrijk om eerst zeker te weten dat we in Worksheet Mode zitten en niet in Document
Mode en daarom kiest u nu eerst voor een nieuw worksheet met File→New→Worksheet
Mode (zie figuur 1.1), dan weet u zeker dat u in Worksheet Mode zit. Het worksheet begint
dan met een leeg blad waar linksboven de prompt staat, aangegeven met [> waarachter
een opdracht ingevoerd kan worden. Verder zien we dan nog een menubar (met Edit, View,
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Figuur 1.1 Openen van een nieuw bestand in Worksheet Mode. De input staat ingesteld op
1D, dat wil zeggen Maple Input.

Insert enzovoort) en de toolbar met een aantal knoppen en de contextbar die steeds verandert
naarmate de cursor in een bepaalde context staat van het worksheet (een formule, tekst, input
of een grafiek enzovoort, zie paragraaf 1.2.2). In de menubar zijn niet alle menu’s actief. Het
heeft ermee te maken in wat voor deel van het worksheet we zitten. De knop Plot wordt in de
menubar bijvoorbeeld pas actief als we de cursor in een grafiek plaatsen. Dat geldt ook voor
de knop Plot in de contextbar.

TIP: Alle worksheets bij elk hoofdstuk van dit boek, kunnen op de bijbehorende website
gedownload worden en geopend in Maple 16. Dus het is misschien handig als u het
bijbehorende worksheet erbij neemt en de voorbeelden naspeelt bij het doorwerken van het
boek.

TIP: Een bestaand Maple-bestand openen, kan ook door in de verkenner op het bestand
dubbel te klikken. (Zie paragraaf 1.5.1 als u nog oude bestanden wilt openen die gemaakt
zijn in Classic Worksheet.)

1.2.1 Input in 2D of 1D

Een nieuw werkblad openen in Worksheet Mode. U ziet dan de prompt, aangegeven met [>.
Nu kan er op twee manieren een opdracht aan Maple gegeven worden. Ten eerste kan dat met
het intikken van een opdracht waarbij de instelling in de contextbar op Text staat met Maple
Input, zoals in figuur 1.1. Er kan dan een opdracht met een formule in 1D worden ingetikt,
dat wil zeggen ééndimensionaal, dus alles met dakjes (voor machtsverheffen), sterretjes
(vermenigvuldigen) en deeltekens op één niveau zoals in figuur 1.2 de uitdrukking f ingetikt
is en afgesloten met een puntkomma. Na het afsluitteken (puntkomma) en het drukken op
[Enter] wordt de formule tweedimensionaal en gecentreerd gepresenteerd waarna de prompt
weer klaarstaat in een nieuwe Execution Group, te herkennen aan de vierkante haak links
in de kantlijn voor een pakketje invoer-met-uitvoer, zie figuur 1.2. In figuur 1.4 is ook te
zien wat een Execution Group is. Als deze vierkante haken er niet staan, kijk dan in de
menubar bij View→Show/Hide Contents of de Execution Group Boundaries aangevinkt zijn.
In principe staat alles daar steeds aangevinkt. Zie ook paragraaf 1.5.6 om dingen onzichtbaar
te maken ten behoeve van het printen of iets dergelijks. De boundaries geven aan wat in een
Execution Group bijelkaar hoort; meestal een pakketje input en output.

TIP: Meerdere Execution Groups kunnen bij elkaar gevoegd worden met Edit−→Split or
Join, zodat eventueel een aantal opdrachten achter elkaar wordt uitgevoerd en daarbij wordt
de uitvoer dan ook vlak onder elkaar gepresenteerd. (Zie ook bij Labels paragraaf 1.6.4.)

Het is echter ook mogelijk om 2D-formules in te voeren met in de contextbar Math
en 2D-Input geselecteerd. In dat geval wordt de formule metéén tijdens de invoer al
tweedimensionaal weergegeven zoals de uitdrukking g is ingevoerd in figuur 1.2 en er kan
steeds volop gebruikgemaakt worden van de paletten aan de linkerkant van het worksheet.
Zorg er eerst voor dat de cursor ergens in een invoerregel staat waar de uitdrukking die u wilt
kiezen uit een van de paletten, terecht moet komen. Als er dan iets uit een van deze paletten
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Figuur 1.2 Gebruik van paletten en keuze tussen 1D- en 2D-Input (wisselen met [F5]-toets).
Variabele toekenningen worden bijgehouden in het Variables-palet.

gekozen wordt door middel van aanklikken, dan wordt een tweedimensionale uitdrukking
uit het Expression-palet bijvoorbeeld an in 1D-Input vertaald naar a[n], zoals dat met
mouse-over aangegeven wordt in figuur 1.2. Maar als 2D-Input is ingesteld voor de invoer,
dan komt het ook als subscript in de invoer te staan en dat is te zien met het invoeren van
de functie h1. (Lees meer tips over subscript in paragraaf 5.2 en meer over paletten in
paragraaf 1.3.1).
Na [Enter] wordt de ingevoerde formule weer gecentreerd gepresenteerd in de uitvoer en
staat er weer een nieuwe prompt klaar in een nieuwe Execution Group.

Bij elk van de verschillende manieren van invoeren kan dus gebruikgemaakt worden van de
paletten (bijvoorbeeld het Expression-palet) links van het worksheet waar een template voor
een uitdrukking aangeklikt kan worden. Met de [Tab]-toets kan dan achtereenvolgens elk
onderdeel van de formule naar wens snel ingevoerd worden.
Tussen beide mogelijkheden voor de invoer (1D in het rood en 2D in het zwart), kan naar
keuze gewisseld worden met behulp van de [F5]-toets. Het maakt voor de output (de formule
die als resultaat gecentreerd en in het blauw verschijnt) geen enkel verschil. Lees meer over
paletten in paragraaf 1.3.1.

Figuur 1.3 Wisselen tussen 1D (links) en 2D (rechts) met de [F5]-toets

Na iedere opdracht, bijvoorbeeld de toekenning f:=x^2+2*x+5; als tekst ingevoerd (1D-
Input dus Text en Maple Input), moet beslist een afsluitteken (puntkomma ;) ingetikt
worden om aan te geven dat dit het einde is van de opdracht. Bovendien gaat het hier om
een toekenning en dan moet het teken := gebruikt worden zonder spatie ertussen. Zie ook
figuur 1.3 in de linker situatie. (Voor meer informatie over toekenningen, zie paragraaf 1.6.2.)
Als echter de opdracht met de instelling 2D-Input ingevoerd wordt (Math en 2D Input), is
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het afsluitteken aan het eind van de opdracht niet beslist noodzakelijk, maar mag wel. Verder
moet voor de toekenning ook hier het teken := gebruikt worden.
Na [Enter] is de opdracht bevestigd en verschijnt de output gecentreerd altijd in 2D zoals ook
te zien is in figuur 1.2.
Ook is het bij de 2D-Input niet beslist nodig dat bij het invoeren van formules een ster getikt
wordt tussen bijvoorbeeld 4 en x2 maar het mag wel, want dan verschijnt er in de formule
die ingetikt is een stip ertussen op halve hoogte. Dus niet een stip op het toetsenbord tikken
(zie figuur 1.3) maar een ster! In de output is deze stip weer weg en staat er een spatie.
Als vermenigvuldiging mag ook een spatie getikt worden in de 2D-instelling voor de input.
Men zou kunnen zeggen dat de 2D-Input iets meer gebruikersvriendelijk is. Maar let op dat
de output gecontroleerd dient te worden, zodat er een wisselwerking tussen de gebruiker
en het programma ontstaat met het controleren of een en ander goed begrepen is door het
programma.

TIP: Kijk ook eens in het Common Symbols-palet voor een klein stipje (niet de dikke stip)
als u in de formule een stipje wilt zien. Het betekent hetzelfde als het tikken van een ster
voor de vermenigvuldiging.

TIP: Op één invoerregel kunnen beslist nı́et beide (Text en Math) tegelijk voorkomen.
Het is echter wel mogelijk om achteraf nog de invoerregel te veranderen van 1D naar
2D of andersom met behulp van Format (in de menubar)→Convert To→2-D Math Input
respectievelijk 1-D Math Input.

Links van het werkblad (figuur 1.2) is te zien bij de paletten in de rubriek Variables welke
variabelen tot nu toe in het worksheet gedeclareerd zijn en dat zijn hier de variabelen f en
g waarvoor toekenningen zijn gedaan met het teken := waarmee voortaan vastgelegd is dat
elke f in een volgende opdracht vervangen wordt door x2 + 2x+ 5 enzovoort. Zo kan ook
de naam van de variabele aangeroepen worden om opdracht te geven een grafiek te tekenen.
In het Variables-palet is ook te zien wat voor soort variabele het is. De variabelen f en g
zijn polynomen, te herkennen aan het

∑
-teken vlak voor de letter van de variabele. Voor

de variabele h staat een pictogram van een tabel en dat heeft met subscript te maken. Met
het toekennen van een variabele met subscript is iets bijzonders aan de hand. Later in
paragraaf 5.2 zullen we zien dat het gebruik van subscript speciale betekenis heeft, maar
zoals hier, kan een variabele naam met subscript gewoon gebruikt worden als toekenning.

TIP: Het teken := voor toekenningen is een samengesteld teken. Er mag géén spatie tussen
staan!

1.2.2 Contextgevoelige menu’s

Bekijk nu eerst figuur 1.4 en maak in uw eigen worksheet met de ingevoerde uitdrukkingen
f en g een grafiek hiervan.
Een grafiek maken gaat met het commando plot waarbij in dit geval een verzameling
(aangegeven door middel van accolades) van twee grafieken in één figuur wordt gemaakt
door op een opdrachtregel het volgende te tikken:
> plot({f,g},x=-10..10); wat wil zeggen dat de grafieken van f en g getekend
moeten worden voor het gebied waarbij x loopt van −10 tot en met 10 met twee stipjes
ertussen om deze range aan te geven. Afsluiten met puntkomma en na [Enter] verschijnt de
grafiek als het goed is.

Maple herkent ieder object of omgeving waarop geklikt wordt in het worksheet. Klikken op
de grafiek bijvoorbeeld geeft onmiddellijk een andere gedaante van de contextbar en er kan



1 · Snel aan de slag 5

Figuur 1.4 Context-gevoelige menu’s. Door met de cursor in het plaatje te gaan staan, wordt
de Contextbar aangepast. Achter elke output een label en met de rechter muisknop op een
output klikken, geeft een context-menu.

daarin geklikt worden op Drawing om de figuur aan te vullen met tekentools en tekstvelden
(ook met echte formules in zo’n tekstveld waarbij de paletten gebruikt kunnen worden). De
knop Plot is nu ook actief in de menubar waar deze normaalgesproken niet actief is, maar in
de contextbar is er nu ook een knop Plot en met het klikken daarop, veranderen de knoppen
in deze contextbar en kan de grafiek nog verder aangepast worden wat betreft assen, kleuren
en dergelijke. Zorg er wel voor dat de juiste contextbar actief is bij aanpassingen van het een
of ander. In hoofdstuk 3 wordt verder ingegaan op de grafieken die gemaakt kunnen worden
als eenmaal functies gedeclareerd zijn.

Verder valt in figuur 1.4 op dat achter elke outputregel een nummer staat (1) en (2).
Dit zijn de zogenaamde labels en met behulp van deze labels, kunnen er verwijzingen
plaatsvinden en kan een formule meer keren gebruikt en aangeroepen worden. Eventuele
labels worden automatisch opnieuw genummerd en verwijzingen blijven bestaan als er
opdrachten weggehaald of tussen geplaatst worden. Verwijzingen naar weggehaalde labels
zullen dan natuurlijk niet meer bestaan en in dat geval komen er twee vraagtekens te
staan.
Als deze labels niet verschijnen, dan is het tijd om te kijken in paragraaf 1.3, want dan komen
nu eerst de instellingen om er zeker van te zijn dat bij het maken van een eerste worksheet
we weten wat we aan het doen zijn en dat er niets kwijt kan raken. Meer over labels in
paragraaf 1.6.4.

TIP: Als u met de cursor in een Execution Group staat (te herkennen aan de vierkante haken
links van een pakketje input-output), zijn er weer andere knoppen actief in het menu Edit.
Een hele Execution Group kan als geheel geselecteerd en eventueel weggegooid worden.
Ga dan op een plek in de Execution Group staan en met Edit→Select Execution Group en
vervolgens met de [Delete]-toets is een snelle manier om een Execution Group in zijn geheel
weg te gooien. Met [Ctrl][Delete] kan snel een regel weggehaald worden.
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Verder is het ook interessant om te zien dat met het aanklikken met de rechtermuisknop
van een 2D-input of een 2D-output er bij verschillende objecten steeds bijpassende context-
menu’s verschijnen. Klik eens op de output van zo’n ingevoerde uitdrukking en bekijk wat
er allemaal mee gedaan kan worden. Gaandeweg in deze handleiding wordt duidelijk wat
de betekenis is van deze menuopties, zodat met alle mogelijke muisklik-acties er vrijwel
syntax-vrij gewerkt kan worden. In deze handleiding worden er allerlei commando’s gebruikt
waarvan u de syntax niet allemaal hoeft te kennen omdat de meeste commando’s terug te
vinden zijn in de paletten of in de context-menu’s. Bij elk onderwerp in dit boek wordt bij
de behandeling van een commando zo veel mogelijk ook verwezen naar de context-menu’s
als ze daar ook in te vinden zijn. Lees daarom ook steeds de TIP die bij de uitleg van een
commando staat.

Als later tekst wordt toegevoegd aan het worksheet, zoals te zien is in figuur 1.9, en men gaat
met de cursor in de tekst staan, dan wordt het context-menu ook daarop aangepast en in de
menubalk zullen er weer aangepaste knoppen verschijnen alsook in de contextbar.
Context-menu’s spelen een grote rol bij het syntax-vrij werken met Maple, zodat er eigenlijk
nauwelijks kennis van de commando’s nodig is wat syntax betreft. In hoofdstuk 7 maken
we geavanceerde documenten waarbij er geen zichtbare inputregels meer voorkomen in het
document. De kennis van de syntax van de commando’s is dan niet direct nodig, maar de
betekenis ervan des te meer!

1.3 Belangrijke instellingen

De belangrijkste instellingen voor het programma kunnen nu allemaal eerst gecheckt worden
om in de toekomst bij het openen van een nieuw worksheet de juiste instellingen meteen
klaar te hebben. Bevestig steeds met de knop Apply Globally onderaan, zodat elk worksheet
dat op uw computer in uw profiel geopend wordt, deze instellingen heeft.
In de menubar bij Tools→Options→tabblad General controleert u of Auto save is
aangevinkt.
LET OP: Auto save werkt alleen als het worksheet al een naam heeft gekregen. Sla het
nieuw te beginnen worksheet altijd eerst op onder een naam.
Met de instelling Create a new engine for each document voorkomt u, als u meer dan één
worksheet onder handen hebt, dat de toekenningen van het ene en het andere worksheet door
elkaar gaan lopen.

In het tabblad Display bovenaan kiest u bij Input Display voor Maple Notation, zodat de
invoer altijd 1D is. Daarvan wordt in deze handleiding ook meestal gebruikgemaakt. Maar u
kunt ook kiezen voor 2D en naar omstandigheden kan altijd in het worksheet nog gewisseld
worden tussen de twee notaties met de [F5]-toets. Bij Output display, kiest u natuurlijk voor
2D Math Notation.
In paragraaf 5.4.2 staat informatie over de instellingen wat betreft de Assumed variables.
Verder vinkt u de checkbox aan bij Show equation labels, zodat de formules in de output van
iedere opdracht steeds genummerd worden. Later kunnen de labels verder nog wel aangepast
of uitgezet worden voor ieder worksheet apart via het menu Format→Equation Labels en dan
kan alsnog gekozen worden voor het al of niet zichtbaar maken van de labels. In figuur 1.2
en figuur 1.9 zijn de labels bijvoorbeeld niet zichtbaar en in figuur 1.4 wel. Zie verder voor
het gebruik van labels in paragraaf 1.6.4.

In het tabblad Interface moet u voor Worksheet kiezen bij Default format for new
worksheets, anders hebt u kans dat u onbewust tóch in Document Mode werkt bij het
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Figuur 1.5 Instellingen met Tools → Options. Tabblad General en tabblad Display.

openen van een nieuw workheet en dan werkt het allemaal nogal wat anders.
Ook belangrijk is dat u de checkbox bij Tool tips en Menu tips aanvinkt. Het heeft als effect
dat bij gebruik van de paletten en tools overal de mouse-over-functie is geactiveerd ter
verduidelijking van gebruikte symbolen en uitdrukkingen.
Standaard is Automatic command completion aangevinkt wat ook beslist zo moet blijven (zie
paragraaf 1.7.4).

Figuur 1.6 Instellingen met Tools → Options. Tabblad Interface en tabblad Precision.

Ten slotte kan in het tabblad Precision ten eerste het aantal decimalen in de uitvoer ingesteld
worden met Round screen display to....10 decimal places. Dit aantal decimalen dat getoond
wordt in de uitvoer heeft verder geen invloed op berekeningen die gedaan worden; het gaat
alleen maar om de presentatie in de uitvoer dat het aantal decimalen daarmee eventueel wat
beperkt kan worden. Vink deze optie alleen aan als dat werkelijk noodzakelijk is voor de
presentatie van uw worksheet. Het is namelijk ook mogelijk om tijdens een sessie in het
worksheet het aantal decimalen dat in de uitvoer weergegeven wordt nog halverwege aan te
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passen. Daarom kiezen we ervoor om deze optie NIET aan te vinken, want anders gebeuren
er wellicht onbegrijpelijke dingen (zie paragraaf 1.6.6).
Vervolgens kan het aantal significante cijfers waarmee gerekend wordt ingesteld worden
met Round calculations to ....10 significant Digits. Dit aantal significante cijfers waarmee
gerekend wordt heeft geen invloed op instellingen die gaan over het aantal decimalen dat
gepresenteerd wordt in de uitvoer. Vink deze optie alleen aan als dat werkelijk noodzakelijk
is voor de berekeningen. Het is namelijk ook mogelijk om tijdens een sessie in het worksheet
het aantal significante cijfers dat gebruikt wordt bij een berekening nog ter plaatse aan te
passen. Daarom kiezen we ervoor om deze optie NIET aan te vinken, want anders gebeuren
er wellicht onbegrijpelijke dingen (zie paragraaf 1.6.6).
Dus eerst de belangrijkste instellingen checken met Tools→Options en bevestigen met de
knop Apply Globally in het dialoogscherm van tabblad Precision. De instellingen zijn niet
gekoppeld aan de eigenschappen van een worksheet, maar aan de manier waarop u Maple
hanteert op de computer waarop u werkt in uw eigen profiel.

1.3.1 Instellen en gebruik van Paletten

We hebben al gesproken over paletten aan de linkerkant van het worksheet, zoals het
Expression-palet en het Variables-palet en wellicht hebt u ook al eens gekeken in het
Common Symbols-palet. Het is echter ook mogelijk om de paletten aan de rechterkant in
een ‘dock area’ te zetten of over meer of minder paletten te beschikken en de volgorde aan te
passen. Standaard staan ze links en staan ze nı́et allemaal aan.
Ziet u helemaal geen paletten op uw scherm, kijk dan eens of misschien de dock area’s
dichtgeklapt zijn. In het menu bij View→Palettes→Expand Docks kunnen de dock area’s in
ieder geval weer open gezet worden (aan de linkerkant en de rechterkant van het worksheet).
Met de kleine pijltjes boven naast een dock area kan deze weer gesloten worden.
Om de volgorde van de paletten aan te passen, kunt u de titelbalk van een palet eenvoudig
met de muis verslepen waarmee u het hele palet een andere plaats kunt geven.
Met View→Palettes→Arrange Palettes kan nog veel meer beı̈nvloed worden. Niet alleen
kunt u de volgorde aanpassen door te slepen, maar ook kunt u een aantal paletten uitzetten
met Remove als ze toch niet gebruikt worden. Ook kunt u verborgen paletten activeren. Het
Accents-palet bijvoorbeeld (dat niet tot de standaard paletten behoort en waarmee u streepjes
of pijltjes boven letters plaatst) kunt u met Arrange Palettes met de muis naar het gewenste
dock area verslepen en verder slepen naar een handige plaats in de lijst. Het is bijvoorbeeld
gemakkelijk om het Favorites-palet bovenaan te hebben staan (zie figuur 1.7). Daarin kunt u
symbolen en uitdrukkingen zetten die u zelf vaak wilt gebruiken. Zoek uw favoriete symbool
of uitdrukking op in een van de paletten en klik met de rechtermuisknop erop en kies voor
Add To Favorites Palette, zie figuur 1.7.

In figuur 1.7 is ook te zien dat met mouse-over (als u langzaam met de muis over een
object gaat zonder erop te klikken) de code van een van de uitdrukkingen tevoorschijn
komt in 1D-notatie (sum(f,i=k..n)). Handig als u de codes moet leren kennen. Als die
mouse-over-faciliteit niet bij u aanwezig is, controleer dan of de instellingen daarvoor goed
staan. Zie paragraaf 1.3 bij tabblad Interface bij Tool tips.

Ook is het aardig om bij het Handwriting-palet met de muis bijvoorbeeld een sigma-teken te
maken of een ander teken en dan op de knop met het π-teken te klikken (figuur 1.8). U kunt
dan een keuze maken uit de tekens die vervolgens verschijnen en met het aanklikken daarvan
kan het teken in de tekst geplaatst worden van het worksheet op de plek waar de cursor op
dat moment staat. Het scheelt een hoop gezoek in alle paletten. Klik dan meteen ook met de
rechtermuisknop om het teken eventueel in het Favorites-palet te plaatsen.
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Figuur 1.7 Paletten aanpassen met View→Palettes→Arrange Palettes.

Figuur 1.8 Handwriting-palet

De instellingen voor de paletten blijven bestaan voor de computer waarop u in uw eigen
profiel werkt. Deze instellingen zijn nı́et gekoppeld aan de eigenschappen van het worksheet.

Hou er ook rekening mee dat er verschil is tussen 1D-Input en 2D-Input waarover
in paragraaf 1.2.1 gesproken is. Niet alle paletten ondersteunen de 1D-invoer. Alle
onderdelen van het Expression-palet bieden ondersteuning voor zowel 1D als 2D-Input, maar
bijvoorbeeld het Greek-palet met Griekse letters en bijvoorbeeld het Common Symbols-palet
biedt niet in zijn geheel ondersteuning voor 1D-Input. Sommige tekens daarvan zijn lichtgrijs
en dus niet actief als u in de 1D-Input zit. Schakel dan over op 2D-Input met de [F5]-toets
en dan zijn alle symbolen en uitdrukkingen in ieder geval wél actief. Ten behoeve van de
formules in de tekst kunnen alle paletten volop gebruikt worden (zie in paragraaf 1.4.1).
Immers formules in de tekst zijn altijd 2D.

TIP: Als u bijvoorbeeld een uitdrukking uit het Expression-palet aanklikt, kunt u met
de [Tab]-toets gemakkelijk alle onderdelen van de formule invullen. Dat geldt voor 2D-
Input maar ook voor 1D-Input. Standaard heeft de [Tab]-toets van het toetsenbord binnen
Maple deze genoemde functie. Moet echter in een tekst een tab aangebracht worden (voor
spatiëring) dan zal dit alleen werken als deze functie voor deze toets aangezet wordt door
middel van het knopje in de toolbar (Toggle entry of tab characters with tab key).

TIP: Alle instellingen voor de paletten en ook op welke manier het Favorites-palet is
ingevuld, zijn afhankelijk van de computer waarop u werkt. Elk worksheet dat geopend
wordt, werkt met dezelfde instellingen van de paletten, zoals u dat zelf ingericht hebt op uw
computer in uw eigen profiel.
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1.4 Tekst en opmaak in een Worksheet

Begin een nieuw worksheet met File→New→Worksheet Mode. Als de instellingen goed zijn,
is bovenaan de prompt zichtbaar achter het [>-teken, zie figuur 1.9.

Figuur 1.9 Opmaak van de tekst in een worksheet met titel en paragrafen, formules, bereke-
ningen en tekst.

Klik vervolgens op de T in de toolbar. Er komt dan een nieuwe Execution Group waarin
gewoon tekst getikt kan worden. Zie ook paragraaf 1.4.2 voor informatie over Execution
Groups.
Als u een regel die begint met [> wilt weghalen, selecteer dan deze Execution Group
(Edit→Select Execution Group) en met de [Delete]-toets is deze regel eenvoudig te
verwijderen.
Ook handig is het om in een regel die begint met de opdracht-prompt [> en waar u geen
opdracht in wilt voeren, maar een stukje tekst, dan [Ctrl][T] te doen om tekst te maken
in plaats van een opdracht aan Maple te geven als input. U bent dan in de tekstmode
zoals figuur 1.9. De contextbar lijkt dan op die van een gewone tekstverwerker waarin u
verschillende stijlen kunt kiezen die met een rolmenu te bereiken zijn zoals, Title, Author,
Normal, Numbered Item enzovoort. Na [Enter] kunt u voor een andere stijl kiezen. Ook zijn
er knoppen in de contextbar voor vet, cursief, onderstrepen, gekleurde tekst, centreren en
rechts uitlijnen en dergelijke (zie figuur 1.9).
Wilt u gebruikmaken van superscript (m2) of subscript (a1) in de tekst (dus niet in formules),
tik dan eerst gewoon alles in en selecteer de karakters die superscript moeten. Gebruik
vervolgens in de menubar Format→Character en kies voor Superscript of Subscript. Zie
voor meer informatie over subscript en dergelijke paragraaf 5.2.
Moet er dan weer een regel komen om een opdracht voor een berekening in te voeren,
klik dan op de knop [> in de toolbar waarmee er weer een nieuwe Execution Group wordt
aangemaakt.
Met de knoppen in de contextbar kan het font (lettertype) en de grootte van de letter aangepast
worden evenals de letterkleur en dergelijke. Dat kan trouwens ook met het selecteren van
een stukje tekst en dan komt u met het klikken van de rechtermuisknop in het context-menu
waarin gekozen kan worden voor Format waarmee er allerlei dingen met de tekst gedaan
kunnen worden.
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1.4.1 Formules in de tekst

Als u in de tekst een formule wilt opnemen, zoals ook te zien is in figuur 1.9, klik dan op
Math in de contextbar of gebruik de [F5]-toets om te wisselen tussen tekst en formule. In de
contextbar verschijnt nu 2D Math (en dat is geen 2D-Input). Met een formule in de tekst kan
dan ook niet verder gerekend worden als er gewerkt wordt in Worksheet Mode.
Het intikken van een formule in de tekst (zorg dus dat u in de Math-mode zit), kan met
behulp van de paletten links van het worksheet (zie ook paragraaf 1.3.1), maar ook door
gewoon in te tikken met dakjes, haakjes en sterretjes en dergelijke. Navigeer door de formule
met behulp van de pijltjestoetsen om de cursor te sturen. Een spatie kan doorgaan voor
een vermenigvuldiging, maar mag desnoods ook met een sterretje wat vertaald wordt in
een punt in de formule. Gebruik een dakje voor superscript en een underscore ( ) wordt
vertaald naar subscript in de 2D-formule. Al deze bouwstenen kunt u ook verkrijgen door
in het Expression-palet een uitdrukking aan te klikken. Met de [Tab]-toets kunt u snel alle
onderdelen van zo’n uitdrukking invoeren. Zie daarover ook de TIP aan het eind van de
vorige paragraaf.
Klik na het intikken van de formule weer op Text in de contextbar om door te gaan met
gewone tekst of gebruik de [F5]-toets om te wisselen tussen tekst en formule-mode.

1.4.2 Secties en Execution Groups

Het invoegen van een nieuwe sectie (als kopje van een paragraaf genoemd in figuur 1.9)
gaat met Insert→Section waarbij er ook meteen een Execution Group binnen die sectie
wordt aangemaakt. Een sectie is een paragraaf die eenvoudig open en dichtgeklapt kan
worden. De Execution Group die tegelijk ontstaat bij het aanmaken van een sectie, kunt u
eventueel weghalen als u alleen tekst wilt hebben en geen opdracht wilt geven om iets te
berekenen. Kijk nog even in figuur 1.2 wat een Execution Group is. U kunt vervolgens een
opdracht geven voor een berekening door in de toolbar het knopje [> aan te klikken en
binnen de Execution Group kunt u ook nog één of meer regels tekst plaatsen. Dat gaat met
Insert→Paragraph After Cursor. Dus zet de cursor ergens neer en voeg er tekst tussen met
Insert→Paragraph.
De sectie kunt u open- en dichtklappen door op het driehoekje vlak voor de titel (kopje) van
deze sectie te klikken (figuur 1.9).
Het kopje van deze sectie is automatisch in de stijl Heading 1.
De sectie kan in zijn geheel weggehaald worden door de cursor ergens binnen de sectie
neer te zetten en met Edit→Select Section de gehele sectie te selecteren en dan met de
[Delete]-toets te verwijderen.
Subsecties zijn op dezelfde manier te maken met Insert→Subsection.
Met View→Collapse All Sections of View→Expand All Sections kunt in één keer alle secties
van een heel worksheet dichtklappen resprectievelijk openklappen.

TIP: Eventueel kunt u een gedeelte van het worksheet selecteren en daarvan eenvoudig een
sectie maken met behulp van de knop in de toolbar (Enclose the section in a subsection).

TIP: Als u in de titel van een sectie (inklapbare paragraaf) gaat staan en dan met
Insert→Section een nieuwe paragraaf aanmaakt, komt deze daaronder te staan.

1.5 Openen en opslaan van een Worksheet

Met het dubbelklikken op een bestaand Maple-bestand in de file manager, opent Maple dit
automatisch. Om Maple te openen met Start→Programs, kies dan voor Maple 16.
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Een zelfgemaakt of bewerkt Maple-bestand altijd opslaan met File→Save As als een mw-
bestand (dus niet met extensie mws), zodat het in het vervolg ook steeds automatisch in
de standaard interface geopend wordt. Of er nu in Worksheet Mode of in Document Mode
gewerkt wordt, doet niet ter zake. Het is in beide gevallen een bestand met extensie .mw dus
dat komt vanzelf goed.
Zorg er altijd voor dat een nieuw document direct een naam krijgt en dat Auto save
geactiveerd is (zie paragraaf 1.3 bij de instellingen via Tools→Options in het tabblad
General).

1.5.1 Informatie over Classic Worksheet

Voor gebruikers die in het verleden altijd met Classic Worksheet gewerkt hebben, volgt hier
enige informatie om met oude bestanden om te gaan.

Oudere bestanden die in Classic Worksheet zijn gemaakt, kunnen vaak wel in de nieuwe
standaard interface van Maple 16 geopend worden, maar ingevoegde plaatjes die niet in
Maple gemaakt zijn, gaan dan helaas niet mee. Deze Classic Worksheets van eerdere versies
kunnen wel gewoon bewerkt worden in de nieuwe versie en verder als worksheet behandeld
worden. U kunt ze ook weer opslaan met extensie .mw. Dat is allemaal geen probleem.
Het is zelfs mogelijk om met een speciaal migratie-tool een groot aantal oudere Classic
Worksheet-bestanden in één keer om te zetten naar de standaard interface waarbij u er zelfs
voor kunt kiezen om de 1D-Input tegelijk ook om te zetten in 2D-Input als u dat wenst. Nog
steeds gaan plaatjes die niet in Maple gemaakt zijn dan helaas niet mee, dus wel de grafieken
die door het programma gegenereerd zijn.
Het omzetten kan gewoon gedaan worden als u aan het werk bent in een willekeurig ander
worksheet en heeft geen invloed op het werk waarmee u bezig bent. Het gaat als volgt met
Tools→Assistants→Worksheet Migration Assistant, zie figuur 1.10. Als u ten slotte geklikt
hebt op Start Translation, is het werk in een oogwenk geschied en kunt u dit dialoogscherm
weer sluiten. Voor meer informatie over Assistants, zie paragraaf 1.8 waar de helpfunctie
wordt besproken.

Figuur 1.10 Migration Assistant voor het omzetten van een aantal Classic Worksheets naar
de standaard interface.

Omdat de standaard interface de afgelopen jaren flink verbeterd is, is het niet altijd mogelijk
om mw-bestanden die in nieuwere versies van Maple gemaakt zijn in oudere versies te
openen: er kunnen dan dingen ontbreken. Van oud naar nieuw gaat tegenwoordig prima.
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1.5.2 Exporteren als Word-bestand

Een worksheet kan uitstekend opgeslagen worden als rtf-bestand. Dat gaat met File→Export
As→Rich Text Format (.rtf) en in Microsoft Word kan een dergelijk bestand worden geopend.
Het meeste gaat keurig mee: tekst, plaatjes en formules. De tekst kan in Word zelfs nog
verder aangepast worden en de formules komen als plaatjes (die niet aangepast kunnen
worden) in Word tevoorschijn. Headers en footers gaan echter niet mee, maar die kunnen er
in Word nog aan toegevoegd worden. Ook gaan de boundaries en de labels niet mee.
Wat misschien ook handig is voor de presentatie in het Word-bestand, is eerst de input
weghalen uit het worksheet, zodat alleen de output zichtbaar blijft. Dat kan in het worksheet
voorbereid worden met View→Show/Hide Contents en dan Input uitvinken, zodat in het
worksheet alleen de tekst en de output te zien is.

1.5.3 Exporteren als pdf-bestand

Tegenwoordig worden pdf-bestanden veel gebruikt om documenten uit te wisselen, te printen
en op Internet te zetten. Er zijn goede mogelijkheden om met Adobe Reader het bestand
op het scherm te lezen en zoekopdrachten te starten. Eventueel kan met pdf-software een
inhoudsopgave gemaakt worden.
Het is ook mogelijk om het worksheet als html-bestand weg te schrijven, maar deze manier
van doen is alweer wat verouderd. MapleSoft ontwikkelt de html-conversie niet verder
(zie paragraaf1.5.5). Er is voor gekozen om een goede pdf-conversie aan te bieden (met
File→Export As en dan kiezen voor PDF) die in vele opzichten mooier is dan de html-versie
en prima om van het scherm te lezen. De kopteksten en voetteksten gaan mee evenals de
labels. Eventueel kan het worksheet nog voorbereid worden om bijvoorbeeld boundaries
onzichtbaar te maken (met View→Show/Hide Content) ten behoeve van een mooie lay-
out. Labels kunnen ook eventueel uitgezet worden met het uitvinken van de checkbox bij
Format→Equation Labels.

1.5.4 Slideshow

Het is ook mogelijk om een Slide Show te presenteren met View→Slide Show. Dit vereist
wel even wat voorbereiding. Verdeel daartoe het hele worksheet in secties met eventueel een
enkele korte subsectie (zie paragraaf 1.4.2). Elke sectie moet in zijn geheel op het scherm
passen en anders de sectie in meer secties verdelen. De boundaries voor de secties zijn dan
niet te zien in de Slide Show, maar die van de Execution Groups wel. (Eventueel boundaries
weghalen met View→Show/Hide Content.)
Met de pijltjestoetsen [→] en [←] kan nu door de slideshow genavigeerd worden met dien
verstande dat met deze pijltjestoetsen er steeds naar een volgende sectie wordt genavigeerd.
(Informatie over secties staat in paragraaf 1.4.2.)
Scrollen zal niet lukken en daarom moeten de secties op één schermpagina passen. Als er
voorafgaande aan de eerste sectie iets in het worksheet staat, zoals in figuur 1.9 op pagina 10
te zien is, dan blijft dit stuk steeds in beeld. Om dat te voorkomen kunt u eventueel daarvan
ook een sectie maken. Selecteer het betreffende stuk en met de knop uit de toolbar maakt u
daar een sectie van. Mocht u gebruik willen maken van subsecties, dan kunt u deze subsecties
ter plaatse in de slide show open- of dichtklappen door er met de muis op te klikken.
Voor een goede leesbaarheid van de presentatie op het scherm is het handig om van te voren
in het worksheet alles iets te vergroten met behulp van het vergrootglaasje in de toolbar
of anders met View→Zoomfactor deze op bijvoorbeeld 150% te zetten en dan pas de Slide
Show aan te zetten.
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1.5.5 Opslaan als html-bestand

Het opslaan van het worksheet als html-bestand (met File→Export As en kiezen voor
HTML) wordt niet meer verder ontwikkeld en is minder mooi dan een pdf-bestand om op
Internet te gebruiken. Echter het kan wel eens handig zijn om snel te beschikken over een
inhoudsopgave (tabel of contents) als het om een heel groot worksheet gaat. De secties
en subsecties worden dan automatisch als kopjes in een TOC-bestand gegenereerd (tabel
of contents). Ook is het handig om over de gif-bestanden te beschikken van alle plaatjes,
formules en grafieken in het worksheet. Dat gaat snel als u het worksheet exporteert als html-
bestand. Alle formules en plaatjes komen dan in een aparte map terecht. Verder ontraden we
het maken van html-bestanden van de worksheets.

1.5.6 Printen

Als een worksheet uitgeprint moet worden (met File→Print), is het wellicht handig dit alvast
in het Worksheet voor te bereiden wat betreft zaken die wel of niet zichtbaar moeten zijn
in de print. Paginanummering en kop- en voetteksten kunnen eerst nog aangebracht worden
met View→Header Footer. Deze zijn alleen te zien in de print en niet in het worksheet op het
scherm.
Secties die in het worksheet dichtgeklapt zijn, staan in de print ook alleen met de titel van
de sectie zichtbaar en de inhoud ervan is dichtgeklapt. Ook kunnen de boundaries uitgezet
worden als u dat wilt; het zijn die verticale lijnen in de kantlijn die met View→Show/Hide
Content eventueel uit te vinken zijn. Met File→Print Preview is een en ander eerst te
controleren en vandaaruit kunt u direct het resultaat naar de printer sturen. Zie voor het
aanpassen van de stijl van het worksheet in hoofdstuk 7 paragraaf 7.2.

1.6 Berekeningen met aanwijzingen

Er volgt nu een aantal berekeningen waarbij er uitgegaan wordt van de invoer in Maple-Input:
dus 1D. Er moet dan altijd een afsluitteken in de vorm van een puntkomma (;) achter elke
opdracht meegegeven worden. Echter als de invoer in 2D gegeven wordt, dan hoeft dat niet
per se maar mag het wel. Het is wel handig om dit in alle gevallen toch als gewoonte te doen,
want bij meer opdrachten op één regel (paragraaf 1.6.3) is het ook belangrijk om na iedere
aparte opdracht een afsluitteken mee te geven. Vervolgens kunt u op [Enter] drukken om de
opdrachten te laten uitvoeren.

TIP:
Met het klikken op de drie uitroeptekens in de toolbar wordt het hele worksheet vanaf het
begin opnieuw doorlopen in de volgorde zoals het er staat. Voor de reproduceerbaarheid van
het worksheet is het dus van belang dat de volgorde van berekeningen op elkaar aansluit. Voer
de opdrachten daarom altijd in de juiste volgorde in en plaats niet willekeurig opdrachten
tussen andere opdrachten in. Na opslaan en later weer opnieuw openen van het worksheet
zijn alle toekenningen ongedaan gemaakt. In feite wordt het worksheet opnieuw gestart. Om
alle toekenningen te activeren is het gemakkelijk om in één keer het worksheet met de drie
uitroeptekens helemaal te ‘runnen’.
Met het enkele uitroepteken daarnaast, kunnen de opdrachten in een afzonderlijke Execution
Group apart nog een keer uitgevoerd worden, bijvoorbeeld na aanpassing.
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1.6.1 Afsluitteken en procentteken

Er kan op vrijwel dezelfde manier met gehele getallen gerekend worden als op een gewone
rekenmachine. Let op: vrijwel! Er bestaan wat verschillen in de invoer. Het belangrijkste
verschil is dat een invoerregel altijd afgesloten moet worden met een afsluitteken. Dat kan
een puntkomma zijn of een dubbele punt.

TIP: Bij afsluiting met een puntkomma (semicolon) komt het resultaat van de berekening in
de uitvoer te staan; bij afsluiting met een dubbele punt komt er niets in de uitvoer te staan,
terwijl de berekening wél is uitgevoerd. In beide gevallen kan er verder gewerkt worden met
het resultaat van de berekening.

Met het afsluitteken (puntkomma of dubbele punt) geeft u te kennen dat u klaar bent met het
typen van de opdracht en u kunt dan op [Enter] drukken. Het is niet erg als u het afsluitteken
per ongeluk vergeet. Er komt dan een waarschuwing en de regel kan alsnog gecorrigeerd
worden. Er wordt pas gerekend na een afsluitteken. Het wel of niet intikken van spaties is
onbelangrijk in 1D-Input. In 2D-Input kan een spatie de betekenis van vermenigvuldiging
hebben.

In de Maple-sessie hier onder, wordt precies getoond wat er op het scherm verschijnt.
Lees ook de toelichting en probeer dingen uit met behulp van zelfbedachte voorbeelden. Het
>-teken aan het begin van de invoerregel is de prompt van Maple, deze hoeft dus niet ingetikt
te worden. Vaak wordt een nieuwe sessie met restart begonnen om eventueel bestaande
toekenningen ongedaan te maken, maar het is niet altijd nodig om dat te doen.

> restart; 108/4+3*7;

48

> %+a;

48 + a

> 6^2-6;

30

> 5!:

%-1*2*3*4*5;

0

Toelichting: Merk op dat een opdracht afgesloten door een dubbele punt weliswaar geen
resultaat afdrukt, maar wel oplevert.
Het teken ˆ voor machtsverheffen en de slash / voor delen en het teken ! voor faculteit
(5-faculteit betekent 1 × 2 × 3 × 4 × 5, zie ook bij de standaardfuncties paragraaf 2.2.7
op pagina 48). Het procentteken (%) zoals te zien is in een van de regels in bovenstaande
sessie, levert het resultaat van de laatste invoerregel, ongeacht of deze nu is afgesloten door
middel van een dubbele punt of door een puntkomma (semicolon). Dit handigheidje werkt
tot maximaal drie opdrachten terug. Dus %% levert het resultaat van twee opdrachten terug
en %%% dat van drie opdrachten terug, ongeacht of deze opdrachten wel of niet op dezelfde
regel worden ingetikt. Het is echter niet aan te raden veel gebruik te maken van het procent-
teken, zoals in de rest van het boek te zien is. Maak liever gebruik van namen, zodat het
werkblad beter leesbaar is en er geen onbegrijpelijke berekeningen kunnen ontstaan. Soms
kan het echter wel handig zijn met het procentteken te werken om een mooie eenvoudige
uitvoer te garanderen. Er wordt dan gewerkt met vertraagde evaluatie. Zie voorbeelden in
paragraaf 5.3.1 of aan het eind van paragraaf 2.3.1.
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TIP: Als het commando langer is dan één regel en wordt voortgezet op de volgende regel,
druk dan op [Shift][Enter] om naar de volgende regel te gaan.

1.6.2 Toekenning met namen

Bij het gebruik van namen is het werkblad veel beter leesbaar. Aan een naam wordt een
bepaald getal of bepaalde berekening of uitdrukking toegekend. Gebruik voor namen altijd
letters of lettercombinaties met eventueel cijfers. Begin echter niet met een cijfer aan het
begin van een naam (zie paragraaf 1.6.5) en gebruik ook geen namen die al ergens voor
staan binnen Maple, bijvoorbeeld beschermde namen zoals π en I (zie paragraaf 1.7) of
commando’s waarmee berekeningen uitgevoerd kunnen worden zoals diff.

TIP: Het is belangrijk te weten dat er onderscheid gemaakt wordt tussen hoofdletters en
kleine letters. Er zijn op die manier dus tweemaal zoveel variabelen mogelijk en ook nodig.
Denk bijvoorbeeld maar aan de snelheid v en het volume V.
Meer over namen is te lezen in paragraaf 5.4.

Om bijvoorbeeld af te spreken dat voortaan a altijd gelijk is aan 5! is de volgende toekenning
handig om deze later weer te kunnen gebruiken. Spreek dit af door gebruik te maken van :=
(dubbele punt en isgelijkteken). Dit is het teken voor een toekenning. De dubbele punt met
het isgelijkteken, zonder spatie ertussen, vormen samen één teken voor toekenning. Met een
spatie ertussen wordt het nı́et als zodanig opgevat!

> restart; a:=5!:

a-1*2*3*4*5;

0

Toelichting: Tik niet in dergelijke gevallen alleen een isgelijkteken, want dan is er gewoon
een gelijkheid ingevoerd en géén toekenning. Zie ook bij vergelijkingen paragraaf 2.6 op
pagina 69.
Na het invoeren van de toekenning wordt deze afgesloten met een dubbele punt. In de uitvoer
verschijnt dus de toekenning nı́et na zo’n dubbele punt, maar aan het resultaat te zien van de
opdracht op de volgende regel, is de toekenning wél goed begrepen door het programma.

TIP: Als bijvoorbeeld de naam a een waarde heeft gekregen met behulp van een toekenning,
en de waarde hiervan moet aangepast worden, dan kan verderop in de sessie een nieuwe
toekenning voor a gedaan worden met opnieuw a:=.... De vorige toekenning van a wordt
dan overschreven en alleen de laatste toekenning wordt onthouden. In het Variables-palet
wordt deze nieuwe toekenning bijgehouden.
TIP: Om een toekenning weer ongedaan te maken is een handige truc:
> a:= ’a’;

Vanaf dit moment heeft a zijn eerder toegekende waarde weer verloren.
Hetzelfde effect geeft:
> unassign(’a’);

Zie ook in paragraaf 5.3 voor meer informatie over het gebruik van quotes.
TIP: Merk op dat links in het scherm bij het Variables-palet alles steeds bijgehouden wordt
(figuur 1.11) en daarin staan alle variabelen op alfabet gerangschikt. Met een pictogram
ervoor wordt aangegeven wat voor soort variabele het is. Hier is de variabele a een getal
en daarom staat er een n voor ter aanduiding. Eventueel kan binnen dit Variables-palet een
variabele toekenning ook weer ongedaan gemaakt worden door met de rechtermuisknop te
klikken op betreffende variabele en dan te kiezen voor Unassign. Echter bij het nogmaals
laten uitvoeren van het worksheet (met de drie uitroeptekens in de toolbar), is het beter deze
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Figuur 1.11 Organiseren van variabele toekenningen in het Variables-pakket.

opdracht expliciet te geven in de sessie, als dat de bedoeling is, en niet tussendoor ongemerkt
allerlei toekenningen ongedaan te maken. Voor de reproduceerbaarheid van het worksheet
is het dus beter om de opdracht unassign(a) in het worksheet te geven als de varabele
toekenning van a ongedaan gemaakt moet worden.
Nog drastischer is het om midden in de sessie de opdracht restart; te geven waarmee alle
toekenningen in één keer ongedaan gemaakt worden.
Er is ook een knop in de toolbar om deze actie te bewerkstelligen. Echter voor hetzelfde
effect kan in de sessie dit commando op een regel gegeven worden om de reproduceerbaarheid
van het gehele worksheet te garanderen.
TIP: Als er een commando unassign bestaat, dan bestaat er vast ook het commando assign.
Inderdaad kan in het algemeen dit commando assign ook gebruikt worden om toekenningen
te doen. Met assign(a=5); wordt hetzelfde bereikt als a:=5; Normaal gesproken is dit niet
zo’n handig commando, want ten eerste verschijnt er na dit commando helemaal geen output
en ten tweede kan dit commando niet gebruikt worden om een eerder gegeven toekenning te
overschrijven, tenzij men gebruikt assign(’a’=5); dus met gebruikmaking van quotes om
de evaluatie van deze naam tegen te houden (zie paragraaf 5.3).
Het is wel handig om op de hoogte te zijn van het feit dat het commando assign werkt op
een vergelijking en dat er dan van die vergelijking een toekenning gemaakt wordt. Dit kan
later toegepast worden bij het oplossen van vergelijkingen waar met de oplossing verder
gerekend kan worden (paragraaf 2.6.6).

1.6.3 Meer opdrachten op één regel

Er kunnen meer opdrachten achter elkaar op één regel ingevoerd worden ongeacht of u de
invoer in 1D of in 2D geeft. De opdrachten, gescheiden door het afsluitteken (puntkomma
of dubbele punt) worden dan achtereenvolgens stuk voor stuk afgewerkt alsof ze onder
elkaar zijn ingevoerd. Als echter het afsluitteken vergeten is, wordt er wel gewaarschuwd
met bijvoorbeeld: Warning, inserted missing semicolon at end of statement. Het afsluitteken
kan dan alsnog toegevoegd worden. Ook is het aardig om te merken als er een Warning of
Error komt, dat er op geklikt kan worden. Via Internet wordt er automatisch naar betreffende
pagina van MapleSoft genavigeerd om duidelijkheid te verschaffen over de voorkomende
waarschuwingen.

> 5! ;9+5^3; 8*7;

120
134
56

> xy,y:=5,8;

5, 8

> x+xy+y;

x+ 13
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In dit hoofdstuk worden allerlei commando’s besproken om berekeningen te doen en
formules te manipuleren. We beperken ons eerst voornamelijk tot de zogenoemde top-level
commando’s, dat wil zeggen de commando’s die rechtstreeks toegankelijk zijn en waarbij
er, op een enkele uitzondering na, eerst nog geen pakketten geladen hoeven te worden voor
specifieke onderwerpen (bijvoorbeeld lineaire algebra of grafieken of specialistische tools).
Bij de bespreking ervan wordt ook steeds uitgelegd waar deze commando’s te vinden zijn in
de context-menu’s en in de paletten, zodat het in feite mogelijk is om, zonder de syntax van
de commando’s te kennen, toch verstandige acties te doen waarvan de betekenis helder is.

Tevens is het verhelderend om uitleg te krijgen over de verschillende standaardcommando’s
om eventueel te kunnen gebruiken bij het maken van geavanceerde toetsitems bij het
toetssysteem Maple T.A. om daarbij zo min mogelijk zelf te hoeven doen en zo veel mogelijk
te kunnen uitbesteden aan het onderliggende computeralgebrasysteem Maple.

2.1 Inleiding complexe getallen

Maple rekent per definitie altijd met de complete getallenverzameling van de complexe
getallen, maar dat is niet altijd merkbaar! Beter is het om hiervan wél direct op de hoogte te
zijn, zodat de werking van het programma transparanter wordt. Het is ook om die reden dat
we al direct met de basisbewerkingen van het rekenen met complexe getallen beginnen.
Een heel eenvoudig voorbeeld illustreert het rekenen met complexe getallen. Neem
bijvoorbeeld de vergelijking x2 + 4 = 0 die in de reële getallen niet oplosbaar is, maar in de
complexe getallen wel.

> restart; verg:=x^2+4=0;

verg := x2 + 4 = 0

> solve(verg,{x});
{x = 2 I}, {x = −2 I}

De uitleg van het oplossen van vergelijkingen in het algemeen staat verder in paragraaf 2.6.
Als het beslist moet, kan het programma eventueel geforceerd worden om met de beperkte
verzameling van alleen de Reële getallen te rekenen. Daarover staat meer in paragraaf 5.5.

De imaginaire eenheid heeft bij Maple de naam I. Een introductie daarover is al in het eerste
hoofdstuk aan de orde gekomen in paragraaf 1.7.1. In de wiskunde schrijven we meestal
i en bij elektrotechniek wordt vaak de j gehanteerd. Het betekent allemaal hetzelfde. De
imaginaire eenheid wordt gedefinieerd als i =

√
−1 of ook wel als i2 = −1.

Voor het afspreken van een andere naam voor de imaginaire eenheid om mee te rekenen,
bijvoorbeeld de kleine letter i of de j, kan aan het begin van het Worksheet de opdracht
ingevoerd worden om dat af te spreken met interface(imaginaryunit=j), zoals een
voorbeeld in paragraaf 2.1.2. Bij gebruikmaking van 2D-Input is het misschien goed om te
weten dat er meer mogelijkheden zijn om de imaginaire eenheid in te voeren in de input van
een opdrachtregel om er zeker van te zijn dat er op de juiste manier mee gerekend wordt.
Dat kan gewoon met het tikken van hoofdletter I met het toetsenbord waarmee in de uitvoer
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ook een grote I verschijnt (niet cursief) en dan weet het programma genoeg. Deze naam I is
namelijk gereserveerd voor de imaginaire eenheid.

TIP: Ook kan de kleine letter i of j in de input ingevoerd worden met het Common Symbol-
palet of met gebruikmaking van de Complete Command-faciliteit, dus met de [Esc]-toets,
zoals in figuur 2.1 te zien is. In de uitvoer wordt dat vertaald met de hoofdletter I. Verder
staat in paragraaf 1.7.1 uitgebreid informatie over deze letter I.

Figuur 2.1 Complete Command-faciliteit. Hier in de 2D-Input de i intikken en vervolgens op
de [Esc]-toets drukken geeft een Complete Command-menu.

2.1.1 Reële deel en imaginaire deel

Elk complex getal bestaat uit een reëel deel en een imaginair deel. Bij Reële getallen merken
we er niet zoveel van dat Maple in de complexe getallen rekent, maar dat gebeurt wél. Maple
rekent dan alsof de imaginaire delen van de getallen gelijk zijn aan 0. De letters in een
formule kunnen variabelen of parameters zijn die ook getallen kunnen voorstellen en dan
niet alleen gewone reële getallen, maar dus ook complexe getallen.

Er worden in de volgende sessie twee getallen ingevoerd en er wordt gekeken wat het reële
deel is en wat het imaginaire deel is met behulp van de commando’s respectievelijk Re en Im

(met hoofdletter):

> restart; z[1]:=3+5*I;z[2]:=x+I*y;

z1 := 3 + 5 I
z2 := x+ y I

> Re(z[1]);Im(z[1]);

3
5

> Re(z[2]);Im(z[2]);

�(x+ y I)
�(x+ y I)

> evalc(Re(z[2]));evalc(Im(z[2]));

x
y

Toelichting: In bovenstaande zien we dat het bepalen van het reële deel en het imaginaire
deel van het complexe getal z1 = 3+5 i geen probleem is voor Maple als er getallen gebruikt
worden. Het wordt echter lastiger als er parameters of variabelen in het spel zijn, zoals bij het
getal z2 = x + i y. Met het commando evalc (evalueer complex) laten we het programma
weten dat de onbekende parameters (zoals hier de x en de y) reële getallen zijn!
Voor het reële deel en het imaginaire deel is er een mooie kalligrafische letter in de uitvoer
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te zien als de berekening niet gedaan kan worden. Deze kalligrafische letters R voor reële
deel en I voor imaginaire deel ten behoeve van 2D-Input, zijn ook te vinden in het Common
Symbol-palet en worden vertaald in 1D-Input naar respectievelijk Re en Im. Zet eventueel
deze tekens, als ze vaak gebruikt worden, in het Favorites-palet. (Zie paragraaf 1.3.1)

TIP: Voor subscript kunt u de uitdrukking an uit het Expression-palet nemen (dat in
1D-notatie wordt vertaald naar a[n]). Zie voor belangrijke informatie over subscript in
paragraaf 5.2.

TIP: Er worden in het voorbeeld hierboven steeds twee opdrachten op één regel ingetikt
om ruimte te besparen. Informatie over meer opdrachten op één regel is te vinden in
paragraaf 1.6.3 waar ook te zien is hoe er meervoudige toekenningen gedaan kunnen worden
in een rijtje waardoor het nóg korter wordt.

TIP: Voor de berekening met parameters in een formule is het dus noodzakelijk dat het
commando evalc (evalueer complex) gebruikt wordt als we het programma willen laten
weten dat de parameters staan voor reële getallen. Dit commando is niet zo gemakkelijk te
vinden in het context-menu, maar als er op een formule geklikt wordt waarin de imaginaire
eenheid voorkomt én er komen ook parameters in voor, dan past het context-menu zich aan
en ziet u daarin in ieder geval Complex Maps. Kies daarin voor Transform to a+bI form en
dat is dan in feite het commando evalc. Zie in het linker deel van figuur 2.2 waarin ook Real
Part en Imaginary Part staan; voor het reële deel en het imaginaire deel.

Figuur 2.2 Context-menu voor complexe getallen. Links als er parameters in de formule staan
en rechts als er geen parameters in de formule staan.

Als de vorm geen parameters bevat, maar wel de imaginaire eenheid I, dan past het context-
menu zich weer aan en dan ziet u de meeste commando’s die voor complexe getallen gebruikt
kunnen worden, rechtstreeks in het context-menu staan (zie het rechter deel van figuur 2.2).

2.1.2 Andere naam voor de imaginaire eenheid

Het is voor elektrotechnici van belang dat de formules in rapporten eruit komen te zien
in herkenbare vorm. Het is wenselijk om overal de letter j te gebruiken als de imaginaire
eenheid bedoeld wordt. Dit kan verwezenlijkt worden door middel van een afspraak aan het
begin van de sessie: interface(imaginaryunit=j);
Zodra deze afspraak gemaakt is, kan eventueel met 2D-Input met Command Complete met
de [Esc]-toets gewerkt worden of met het invoegen van de letter j uit het Common Symbols-
palet. In de output zal dat sowieso de (niet-cursieve) letter j worden. Er kan ook gewoon de
j vanaf het toetsenbord ingevoerd worden, want die staat nu volgens afspraak voortaan per
definitie voor de imaginaire eenheid. Het spreekt vanzelf dat de hoofdletter I nu gebruikt
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kan worden voor namen van andere variabelen en dit is dan geen gereserveerde naam meer.
Na het commando restart is de afspraak dat j de imaginaire eenheid is, weer ongedaan
gemaakt en zal het programma voor de imaginaire eenheid weer de letter I gebruiken.

> restart;interface(imaginaryunit=j); z:=1/R+j*omega*C+1/(j*omega*C);

I

z :=
1

R
+ ω C j− j

ω C
> evalc(z);

1

R
+ j (ω C − 1

ω C
)

> Re(z)=evalc(Re(z)); Im(z)=evalc(Im(z));

<( 1
R

+ jω C − j

ω C
) =

1

R

=( 1
R

+ jω C − j

ω C
) = ω C − 1

ω C
Toelichting: Met de opdracht interface(imaginaryunit=j); en afgesloten met
puntkomma, zien we in de uitvoer een I staan. Er wordt hiermee aangegeven wat
oorspronkelijk de afspraak was voor deze imaginaire eenheid. Als we die uitvoer niet
willen zien, is afsluiten met dubbele punt een optie.
Als de afspraak voor de nieuwe naam voor de imaginaire eenheid gemaakt is, kan in de
invoer steeds het beste deze nieuwe letter gehanteerd worden gewoon met het toetsenbord.
In de uitvoer wordt deze nieuwe afspraak dan ook meteen meegenomen en het programma
rekent er dan als zodanig mee wat te zien is aan de niet-cursieve letter j. Als het een gewone
variabele zou zijn, dan werd deze immers cursief afgebeeld.
Voor het reële deel en het imaginaire deel is er een mooie kalligrafische letter in de uitvoer te
zien (ook te vinden in het Common Symbols-palet) als het programma in het duister tast en
het reële deel en imaginaire deel niet berekend kunnen worden. Immers de variabelen C en
R kunnen ook complexe getallen voorstellen.
Griekse letters kunnen uit het Greek-palet worden gekozen die eventueel direct naar 1D
vertaald worden naar bijvoorbeeld in dit geval omega als men de invoer in 1D-Input geeft.
Voor de berekening is het dus noodzakelijk, bij parameters in een formule, dat u het
commando evalc (evalueer complex) gebruikt om het programma te laten weten dat de
parameters staan voor reële getallen.

TIP: Na restart is de instelling met interface(imaginaryunit=...) weer onge-
daan gemaakt. Dat is anders dan bij interface(displayprecision=...) zoals in
voorbeeld 1.4 op pagina 22 uiteengezet is.

TIP: Wordt er in één en hetzelfde worksheet gebruikgemaakt van verschillende symbolen
voor de imaginaire eenheid, dan kan tóch met labelreferenties gewerkt worden. De naam van
de imaginaire eenheid wordt vanzelf aangepast aan de omgeving waar de afspraak geldt.
Stel in sectie 1 wordt de j gehanteerd voor de imaginaire eenheid en er wordt een output
gegenereerd met labelnummer (1). Als in sectie 2 een restart is gegeven en de imaginaire
eenheid krijgt weer de naam I, dan kan er gerefereerd worden naar het labelnummer (1)
en als er daarmee iets gedaan wordt in paragraaf 2, wordt keurig de letter I gebruikt zoals
passend is in paragraaf 2. Refereren naar een naam zou dan niet kunnen, omdat na restart
de variabele toekeningen immers weer ongedaan gemaakt zijn. Labelreferenties zijn hier dus
in het voordeel!

TIP: Als een worksheet opnieuw geopend wordt, dan zijn de afspraken die met interface
gemaakt zijn weer ongedaan gemaakt. Als u verder wilt gaan met het worksheet waar u
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gebleven bent, is het handig om het worksheet in zijn geheel te laten uitvoeren, zodat alle
toekenningen en afspraken weer geactiveerd worden. Dat kan gemakkelijk met de drie
uitroeptekens (!!!) in de Toolbar.

2.1.3 Basisbewerkingen en complex geconjugeerde

Begin met een paar complexe getallen te definiëren en deze in gedachten een plaats te geven
in het complexe vlak (figuur 2.3):
z1 = 3 + 4 i en z2 = −1 + 3 i.
De complex geconjugeerde van bijvoorbeeld z2 = −1 + 3 i is het complexe getal
z2 = −1− 3 i.
Hoe een en ander in zijn werk gaat, wordt hieronder getoond.

> restart; z[1]:=3+4*I; z[2]:=-1+3*I;

z1 := 3 + 4 I
z2 := −1 + 3 I

> conjugate(’z[2]’)=conjugate(z[2]);

z2 = −1− 3 I

> ’z[1]+z[2]’=z[1]+z[2];

z1 + z2 = 2 + 7 I

> ’z[1]-z[2]’=z[1]-z[2];

z1 − z2 = 4 + I

Toelichting: Met de quotes in bovenstaande sessie wordt de evaluatie tegengehouden, zodat
in de uitvoer duidelijk is wat de betekenis is van de berekeningen. Zie paragraaf 5.3 voor
meer informatie over het gebruik van quotes. Let op dat hier geen toekenningen gedaan
worden, maar dat er gewoon =-tekens zijn ingevoerd en in de uitvoer komt dan een gelijkheid
te staan.

TIP: Het commando conjugate staat ook in het context-menu bij Conjugate (figuur 2.2
op pagina 37) en in de uitvoer komt er een streepje boven de naam te staan als de complex
geconjugeerde bedoeld wordt.

TIP: Eventueel had hier ook de naam i aan de imaginaire eenheid gegeven kunnen worden,
zoals in paragraaf 2.1.2 de naam j werd gehanteerd.

TIP: In figuur 2.3 wordt een en ander in beeld gebracht waarbij het reële deel van het
complexe getal op de horizontale as wordt afgepast en het imaginaire deel op de verticale as.
De complex geconjugeerde van een complex getal van bijvoorbeeld z2 wordt verkregen door
de afbeelding van dit getal in het complexe vlak te spiegelen in de horizontale as (Reële as).
Hoe de figuur gemaakt wordt, komt aan de orde in paragraaf 3.15. Het komt er dus op neer
dat een complex getal ook als vector opgevat kan worden. Het optellen en aftrekken van
complexe getallen is vergelijkbaar met het optellen en aftrekken van vectoren. Zie paragraaf
4.11 hoe er gerekend wordt met de Vectoren in Maple.

TIP: In deze paragraaf is duidelijk geworden dat het complexe getal afgebeeld kan worden
in het complexe vlak en dus ook opgevat kan worden als een vector met twee kentallen:
het reële deel en het imaginaire deel. Het is eventueel ook mogelijk om het complexe getal
in te voeren met het commando Complex (met hoofdletter) als volgt, maar dan moet wel
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Figuur 2.3 Complexe getallen afgebeeld in het complexe vlak. Berekeningen als optellen en
aftrekken van complexe getallen kunnen opgevat worden als bewerkingen met vectoren.

duidelijk zijn dat de gebruikte parameters staan voor reële getallen (dus eventueel werken
met evalc):

> Complex(3,4);

3 + 4 I

> evalc(Complex(x,y));

x+ y I

2.2 Standaardfuncties

Een (standaard)functie bij Maple werkt altijd op dezelfde wijze, namelijk met haakjes.
Bijvoorbeeld sin(x) betekent de sinus van x. Er kunnen op een gemakkelijke manier
functiewaarden worden uitgerekend. Bijvoorbeeld sin(π) = 0. Inwendig weet het
programma middels een procedure precies wat het moet doen om de functiewaarden te
berekenen. Een functie is dus eigenlijk een procedure. Er volgt hier een aantal voorbeelden
van vaak gebruikte en bekende functies die in feite zo voor het grijpen liggen in het
Expression-palet. Bij iedere functie in deze paragraaf staat een korte uitleg van de betekenis
ervan. Let er wel op dat Maple alle functies beschouwt als complexe functies. Dus kijk niet
vreemd op bij opdrachten als

√
−3 en ln(−6). Er kunnen dan ook complexe resultaten in

de uitvoer verschijnen die te herkennen zijn aan de I, zoals uitgelegd in paragraaf 2.1. Als
men dat van tevoren weet, kan de uitvoer van Maple beter geı̈nterpreteerd worden. Voor
de rest van de standaardfuncties wordt verwezen naar de helpfunctie. Voer bijvoorbeeld in:
?arcsin; waarmee u direct in de betreffende helppagina komt over de arcsinusfunctie.

TIP: Er zijn wel meer dan 200 functies binnen Maple gedefinieerd waarvan er hier maar
een paar besproken worden om inzicht in het systeem te geven. Om alle functies in Maple
te zien tik eens ?initialfunctions; waarmee u in een helppagina komt van waaruit alle
helppagina’s over de in Maple bekende functies te bereiken zijn.

TIP: In hoofdstuk 3 zullen de grafieken van functies besproken en onderzocht worden.
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TIP: In paragraaf 5.4 wordt besproken hoe er andere namen gegeven kunnen worden aan
bestaande functies die al in Maple gedefinieerd zijn.

2.2.1 Absolutewaardefuncties en wortelfuncties

Voor het doen van de volgende voorbeelden kan ook gebruikgemaakt worden van de paletten
(Expression-palet).

De absolutewaardefunctie abs(..) berekent van ieder getal de afstand tot de oorsprong.
Ook van imaginaire getallen zoals het getal i =

√
−1 (bij Maple bekend onder de naam

I) op de imaginaire as in het complexe vlak, kan de afstand tot de oorsprong gemakkelijk
berekend worden. Van complexe getallen in het algemeen kan de afstand tot de oorsprong in
het complexe vlak met behulp van het commando abs berekend worden. In de Maple-sessie
van figuur 2.4 wordt een aantal commando’s op één regel gegeven. Onder elkaar komen de
resultaten van de afzonderlijke opdrachten te staan zoals |−4| = 4 en |−4 + 3 i| = 5.

Figuur 2.4 Veel voorkomende functies staan in het Expression-palet en te gebruiken in 1D én
2D-input.

TIP: De absolute waarde van een uitdrukking kan het beste uit het Expression-palet gehaald
worden als u het commando nog niet kent. In 2D-notatie komt het in de invoer zelfs in de
gedaante |a| te staan en daarin kan de a vervangen worden, zoals in figuur 2.4 te zien is.
Maar er kan in 1D-Input zowel als in 2D-Input ook met abs(..) gewerkt worden door
het in te voeren via het toetsenbord. Het context-menu biedt alleen de optie Modulus als de
aangeklikte uitdrukking de imaginaire eenheid bevat.

De wortelfunctie (sqrt) hebben we al leren kennen in voorbeeld 1.2 op pagina 21. In
figuur 2.5 is te zien hoe deze ingetikt kan worden in 1D-Input.

Toelichting: Het commando simplify(%) betekent: ”vereenvoudig het voorgaande
resultaat” en dit commando kunt u ook uit het context-menu halen, zoals te zien in figuur 2.6.
Het wortelteken kunt u eventueel in het Expression-palet aanklikken. In figuur 2.4 op pagina
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Figuur 2.5 Invoeren van wortels en het commando symplify.

41 is te zien dat de wortel uit −3 dus wél kan, omdat per definitie in de complexe getallen
gerekend wordt.

TIP: Ga ook eens op onderzoek uit als u een uitdrukking ingetikt hebt met een variabele,
bijvoorbeeld

√
a. Geef in dit geval voor mogelijke waarden van a ook eens negatieve

waarden op en laat numeriek de uitdrukking doorrekenen. Onderzoek kan gemakkelijk
gedaan worden met de Exploration Assistant die te bereiken is door met de rechtermuisknop
op de uitvoer te klikken (of op de 2D-invoer) en in het context-menu te kiezen voor Explore.
Zie figuur 2.6 hoe achtereenvolgens instellingen gedaan zijn in deze Exploration Assistant.
In paragraaf 2.6 staat nog een voorbeeld van deze Exploration Assistent die als een apart
worksheet te bewaren is. Als de imaginaire eenheid in dit aparte worksheet voorkomt, wordt
deze weergegeven in de standaardgedaante van de imaginaire eenheid I, ook al zijn de
instellingen daarvoor in het Worksheet waarin u werkt, aangepast. Hier is goed te zien dat
een negatief argument voor de wortelfunctie een complex getal als resultaat geeft.

Figuur 2.6 Klik met de rechtermuisknop op de 2D-invoer of op de uitvoer
√
a en kies voor

Explore. Vul vervolgens een range in voor de variabele en kies voor floating-point. Met Explore
kan met een schuifbalk snel onderzocht worden wat het effect daarvan is op de aangeklikte
uitdrukking.

2.2.2 Goniometrische en cyclometrische functies

Bij goniometrische functies is het belangrijk te weten dat de hoek in radialen opgegeven
moet worden. Als u de sinus van bijvoorbeeld 45◦ wilt uitrekenen, dan moeten de graden
eerst omgezet worden naar radialen. Dus sin(45◦) = sin(π4 ).
Als u bijvoorbeeld invoert: sin(20), wordt dit opgevat als de sinus van 20 radialen. Let op
dat sinx beslist nı́et opgevat wordt als de sinus van x. Het typen van sin*x is helemaal uit
den boze.

Sinus- en cosinusfunctie
De sinus van 45◦ en de cosinus van 1.2 radialen kunnen als volgt berekend worden:
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> sin(Pi/4); cos(1.2); √
2

2
0.3623577545

Graden en radialen
Een truc om toch gemakkelijk met graden te kunnen werken is de volgende. Bekend is dat π
radialen overeenkomt met 180◦, dan is α graden dus α × π

180 radialen. Om de cosinus van
20◦ te berekenen, kan voorlopig als volgt gewerkt worden.

> restart; graden:=evalf(Pi/180);

graden := 0.01745329252

> cos(20*graden);

0.9396926208

TIP: In paragraaf 5.6 is meer informatie over eenheden te vinden om dit met graden en
radialen wat officiëler aan te pakken.

TIP: Zet het aantal gepresenteerde decimalen eventueel wat lager met bijvoorbeeld
interface(displayprecision=3); zoals in paragraaf 1.6.6 is behandeld.

Cyclometrische functies zoals arcsin, arccos en arctan, worden op volkomen
natuurlijke wijze ingevoerd. Deze staan helaas niet in de paletten. Houd er steeds rekening
mee dat in de wiskunde met radialen gewerkt wordt. De uitkomst van bijvoorbeeld
arcsin(0.6) is een hoek in radialen! Het omzetten van radialen naar graden kan met behulp
van convert(..,degrees).

> restart; arcsin(0.6): %=evalf(convert(%,degrees));

0.6435011088 = 36.86989764 degrees

TIP: Als u buiten het domein [−1, 1] van bijvoorbeeld de arcsinusfunctie werkt, dan zal
er een complexe functiewaarde teruggegeven worden. Meestal werken we in de praktijk
zelf altijd met de reële functie arcsinus die dus een beperkt domein heeft. Ook dergelijke
functies van één variabele kunt u met de Exploration Assistant onderzoeken, zoals te zien is
in figuur 2.6.

2.2.3 Complexe getallen, modulus en argument

De modulus r en het argument φ van een complex getal zijn de poolcoördinaten en te
krijgen met de commando’s abs en argument. Deze zijn ook te vinden in het context-menu
(figuur 2.2 op pagina 37) zodra een uitdrukking de imaginaire eenheid bevat.
Bekend moet zijn dat de modulus r van het getal a+ i b gevonden wordt met r = |a+ i b| =√
a2 + b2.

Voor het argument geldt φ = arg(a + i b) = arctan( ba ) als het complexe getal in het
rechterhalfvlak ligt óf er geldt φ = arg(a+ i b) = arctan( ba )± π als het complexe getal in
het linkerhalfvlak van het complexe vlak ligt.

TIP: Om in één keer beide poolcoördinaten r en φ te krijgen, is het omzetcommando
convert(..,polar) zeer geschikt. Het is eventueel ook te vinden in het context-menu bij
Conversions (figuur 2.2 op pagina 37).

Voorbeeld 2.1 Poolcoördinaten en vermenigvuldigen
Voor het volgende voorbeeld worden de complexe getallen z2 en z3 ingevoerd.
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> restart; z[2]:=-1+3*I; r[2]:=abs(z[2]);

phi[2]:=argument(z[2]);convert(z[2],polar);

−1 + 3 I√
10

−arctan(3) + π

polar(
√
10, −arctan(3) + π)

> z[3]:=-2.45+I*3.4; r[3]:=abs(z[3]);

phi[3]:=argument(z[3]);convert(z[3],polar);

−2.45 + 3.4 I
4.190763654
2.195206676

polar(4.190763654, 2.195206676)

> abs(z[2]*z[3])=evalf(r[2]*r[3]);

13.25235828 = 13.25235828

> argument(z[2]*z[3])=evalf(phi[2]+phi[3]-2*Pi);

−2.195431750 = −2.195431750
> zz:=convert(z[2]*z[3],polar);

polar(13.25235828, −2.195431750)
> z[2]*conjugate(z[2])=r[2]^2;

10 = 10

Toelichting: Aan het argument van z2 is te zien dat dit complexe getal in het linkerhalfvlak
van het complexe vlak ligt (zie ook figuur 2.3). Dat geldt ook voor z3: het argument is groter
dan π

2 . Voor het argument wordt altijd de hoofdwaarde genomen : de hoek in radialen in het
interval 〈−π, π].

TIP: Als u numeriek wilt rekenen, kunt u het commando evalf gebruiken óf de toekenningen
met decimale getallen invoeren waarna er vanzelf numeriek gerekend wordt door het
programma, eventueel met minder decimalen in de uitvoer. Zie paragraaf 1.6.6 voor het
omgaan met decimale getallen en het commando evalf.

TIP: Als u meer opdrachten op één regel tikt en u wilt toch naar een nieuwe regel, tik dan
[Shift] [Enter].

TIP: Subscript en Griekse letters kunt u eventueel ook uit de het Expression-palet
respectievelijk het Greek-palet halen.

Vergelijk nu eens de poolcoördinaten van z2, z3, en z2 · z3 met elkaar en ga in het voorbeeld
na of het volgende klopt:

|z2 · z3| = |z2| · |z3|
arg(z2 · z3) = arg(z2) + arg(z3) (eventueel aangevuld met ± 2 k π

voor de hoofdwaarde van het argument.)
z2 · z2 = |z2|2

Ga ook eens na of het klopt dat bij een deling de argumenten van elkaar afgetrokken worden
(eventueel gecompenseerd met een geheel aantal malen 2π) en de absolute waarden op
elkaar gedeeld worden.
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2.2.4 De exponentiële functie en de logaritmische functie

De exponentiële functie ex, met het natuurlijke grondtal e ≈ 2.718, wordt in boeken soms
geschreven als exp(x) . Als u bij Maple dit getal e (getal van Euler) los wilt invoeren in 1D,
moet u exp(1) intikken. Zie ook bij het Expression-palet in hoofdstuk 1 paragraaf 1.3.1 en
verder nog paragraaf 1.7.
Als u met 2D-Input werkt, dan moet het programma weten dat het om de speciale e gaat.
Tik dus niet in ex in 2D-Input, want dan is dit niet per definitie het getal van Euler maar
een gewone variabele naam e. Gebruik dan het Expression-palet of maak gebruik van de
Complete Command faciliteit met de [Esc]-toets (zie figuur 2.7). De exponentiële functie ex

kunt u in 1D én in 2D altijd invoeren met het toetsenbord: exp(x).

Figuur 2.7 Gebruik voor 2D-Input het Expression-palet (waar ook de 1D-vertaling te zien is
met mouse-over) of werk met de [Esc]-toets voor de Complete Command faciliteit en kies voor
de Exponential ’e’. De eerste invoerregel in deze figuur is NIET de exponentiële functie met
het grondtal van Euler! De e is daar cursief in de uitvoer!

> restart; exp(5): %=evalf(%);

e5 = 148.4131591

> 1/exp(1): %=evalf(%);

1

e
= 0.3678794412

Er kan van alles uitgerekend worden en met evalf (evalueer met floating point) kan het
vervolgens benaderd worden.
Er is hier, ten behoeve van een mooie uitvoer, gebruikgemaakt van de dubbele punt als
afsluitteken. Het resultaat van een opdracht wordt in zo’n geval niet zichtbaar. Het %-teken
verwijst naar het resultaat van de laatst uitgevoerde opdracht. Zie voor het gebruik van de
dubbele punt als afsluitteken in paragraaf 1.6.1.

De logaritmische functie is bij Maple bekend onder de functienaam ln. Hiermee wordt de
natuurlijke logaritme bedoeld. Het grondtal is het getal van Euler: de letter e ≈ 2.718 .

Figuur 2.8 Het Expression-palet kan zowel bij 1D-Input als 2D-Input gebruikt worden.
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Toelichting: Als een ander grondtal dan het getal e nodig is, dan kan dat met subscript; het
intikken van vierkante haakjes. Dus log3(27) (het grondtal is hier 3) wordt ingevoerd als
log[3](27) en vervolgens wordt in dit geval de opdracht direct vereenvoudigd tot 3 in de
uitvoer. Dus als de logaritme met grondtal 10 bedoeld wordt, bijvoorbeeld log10(95), dan
moet er ingevoerd worden log[10](95). De vorm met een ander grondtal dan e, wordt door
het programma onmiddellijk herleid tot een vorm met de natuurlijke logaritme. In sommige
boeken komt nog voor dat het grondtal van de logaritme links boven de log staat zoals
10 log(x) maar de betekenis is hetzelfde.

TIP: Als u per ongeluk log invoert in plaats van ln, wordt dit opgevat als de natuurlijke
logaritme en beslist nı́et als de logaritme met grondtal 10.

TIP: Er wordt soms geschreven ln2 x terwijl er dan bedoeld wordt: (ln(x))2. Als u invoert:
ln(x)^2, betekent dit hetzelfde als (ln(x))^2. Probeer het verschil met ln(x^2) te zien.

TIP: Met het Expression-palet kunt u de logaritmische functies gemakkelijk invoeren en als
u de invoer op 2D-Input zet met de [F5]-toets, is dat misschien nog wel zo mooi zoals in
figuur 2.8 te zien is.

TIP: Als u per se in een bepaald document in een formule in de tekst toch het grondtal
linksboven van de log wilt hebben zoals 3 log(x), dan kan dat in een formule in de tekst wel
verwezenlijkt worden met de toetsencombinatie [Ctrl][Alt][P] en vervolgens de letter ö die
dan verschijnt, vervangen door het grondtal van de logaritme. Het is de enige manier om deze
presuperscript te doen. Er kan dan echter niet mee gerekend worden, dus in de 2D-Input kan
het niet met deze betekenis gebruikt worden ten behoeve van berekeningen.

2.2.5 De formule van Euler

Met interface(imaginaryunit=i): r*exp(i*phi): %=evalc(%); is het complexe
getal met modulus r en argument φ ook te schrijven als het volgende, wat bekend staat als de
formule van Euler.

r eiφ = r cos(φ) + i r sin(φ)

De vorm z = r eiφ heeft veel voordelen boven de vorm a + i b. Er kan met de gedaante
z = r eiφ vaak beter handmatig en inzichtelijk gerekend worden als het om bijvoorbeeld
vermenigvuldigen gaat. Ook delen, worteltrekken, logaritme nemen en nog vele andere
berekeningen zijn transparanter met de exponentiële vorm door te kijken naar de modulus r
en het argument φ. Er is echter geen commando om van de vorm a+ i b over te gaan naar de
vorm r eiφ. Hooguit kan de vorm omgezet worden in poolcoördinaten. Met het commando
evalc (zie paragraaf 2.1.1) kan de vorm a+ i b altijd wel weer verkregen worden.
Als u decimale getallen invoert, rekent Maple alles zover mogelijk uit totdat de vorm
a + i b weer tevoorschijn komt. De vorm r eiϕ is dan niet meer terug te krijgen. Soms, als z
beschreven wordt met cosinus- of sinusfuncties, is het te proberen om de omzetting naar de
exponentiële vorm te krijgen met convert(..,exp).

> cos(x):%=convert(%,exp);

cos(x) =
1

2
ex I +

1

2
e−I x

TIP: Er wordt hier handig gebruikgemaakt van het procentteken en het afsluitteken dubbele
punt. De dubbele punt zorgt ervoor dat de opdracht wel uitgevoerd wordt, maar het resultaat
ervan niet zichtbaar is en het procentteken verwijst naar het voorgaande dat dus niet zichtbaar
is en in tweede instantie zichtbaar gemaakt wordt.
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TIP: Kijk ook eens naar paragraaf 2.2.6 voor de berekeningen met oneigenlijke machten en
logaritmen als de poolcoördinaten van een complex getal worden gehanteerd.

TIP: Bestudeer eens de prachtige formule waarin de universele constanten 1, 0, π, e en de
imaginaire eenheid i in één vergelijking verenigd zijn en breng deze in verband met de
formule van Euler.

eπ i + 1 = 0

2.2.6 Oneigenlijke machten

Voor oneigenlijke machten zoals (8)
1
3 of ook wel geschreven als 3

√
8: de derdemachtswortel

uit 8, zijn er meer mogelijkheden met verschillende betekenissen. De wortelfunctie is in feite
een meerwaardige functie.
Ten eerste kunt u uit het Expression-palet het symbool n

√
a halen. Dan wordt 3

√
8 vertaald

naar (8)
1
3 .

Met de opdracht root(8,3) wat ook de derdemachtswortel uit 8 betekent, wordt hetzelfde
bereikt. In feite is er dus geen verschil tussen de invoer root(a,n) en a^(1/n).
Er is echter nóg een commando dat niet in de paletten of de context-menu’s staat en dat is
het commando surd.
Voor gewone positieve reële getallen is er tussen de drie mogelijkheden: met het wortelteken
of de schrijfwijze met de gebroken macht, het commando root en het commando surd geen
verschil te merken: root(8,3)=surd(8,3). Maar als u bijvoorbeeld negatieve getallen
of complexe getallen als argument gebruikt, is het een ander verhaal. Met behulp van het
voorbeeld 3

√
−8 laten we het verschil zien tussen root en surd door te kijken naar de

achterliggende definitie van deze twee commando’s.
In figuur 2.9 wordt op de drie verschillende manieren de derde machtswortel uit −8 berekend.

Figuur 2.9 Oneigenlijke machten. De derde machtswortel uit −8 op drie manieren.

Toelichting: De eerste manier is die met behulp van het Expression-palet, dus in feite met de
schrijfwijze van de gebroken exponent. De tweede manier met root(-8,3) levert in feite
hetzelfde resultaat. Beide manieren hebben als definitie: n

√
a = a

1
n = e

1
n ln(a).

Bij gebruik van deze definitie wordt voor de logaritme van a altijd de hoofdwaarde van het
argument van het (complexe) getal a genomen en in dit geval dus de logaritme van −8.

3
√
−8 = (−8)

1
3 = e

1
3 ln(−8) = e

1
3 ln(8·eπ i) =

e
1
3 ln(23·eπ i) = eln(2)+

π
3 i = 2 · eπ

3 i =

2 (cos(
π

3
) + i sin(

π

3
)) = 1 + i

√
3

De definitie van surd is anders. Daar wordt uitgegaan van het argument van het getal
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waarvan de oneigenlijke macht wordt genomen (in dit geval dus −8). Alle mogelijkheden
van deze meerwaardige functie worden onderzocht en van deze mogelijkheden wordt dı́e
gekozen waarvan (de hoofdwaarde van) het argument het dichtst bij het argument van
het oorspronkelijke getal ligt. De hoofdwaarde van het argument ligt altijd in het interval
〈−π, π].

(−8)
1
3 = (8 · eπ i+2 k π i)

1
3 = 8

1
3 · eπ i

3 + 2
3 k π i

k = 0 → 2 · e 1
3π i = 1 + i

√
3

k = 1 → 2 · eπ i = −2

k = −1 → 2 · e
−1
3 π i = 1− i

√
3

Voor k = 0 is het argument dus 1
3π, voor k = 1 is het argument precies π en voor k = −1 is

het argument −1
3 π.

Per definitie is dus voor het commando surd(-8,3) de uitkomst van (−8)
1
3 gelijk aan

−2, want daarvan ligt het argument het dichtst bij het argument van −8; in dit geval is het
namelijk gelijk. Immers π is zowel het argument van −8 als van −2.
Het is dus goed om te weten wat er precies gebeurt bij de verschillende rekenwijzen. Zo kunt
u van complexe getallen oneigenlijke machten nemen en met root en surd krijgt u meestal
verschillende takken van de meerwaardige wortelfunctie.

2.2.7 Faculteitfunctie en binomiaalfunctie

Dan hebben we nog tot onze beschikking de faculteitfunctie: n! als n een geheel positief
getal is of 0. Deze functie is bekend onder de functienaam factorial. Als alternatief
van deze functie kan er gebruikgemaakt worden van het uitroepteken in de invoer met het
toetsenbord of met a! uit het Expression-palet (figuur 2.10). De betekenis van 7! is dezelfde
als factorial(7) waarmee bedoeld wordt 1× 2× 3× 4× 5× 6× 7.

Ten slotte is er de binomiaalfunctie:
(
n
k

)
waarbij n en k positieve gehele getallen zijn en

n ≥ k. Deze functie komt vaak voor bij de kansrekening en kunt u via het Expression-palet
invoeren. Zie figuur 2.10.

Figuur 2.10 De binomiaalfunctie en de faculteitsfunctie.

Verder schrijven we bijvoorbeeld 7 boven 2 als
(
7
2

)
. In zowel 1D-Input als 2D-Input kunt u

binomial(7,2) invoeren met het toetsenbord. De betekenis is: 7!
2! (7−2)! .

2.2.8 Functienotatie

Tot nu toe zijn er uitdrukkingen ingevoerd met behulp van een variabele toekenning,
bijvoorbeeld f:=.... Soms werd daarmee een functie van x bedoeld. In de tekst werd
in dat geval gesproken over f(x), bijvoorbeeld als de grafiek van zo’n functie getekend
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moest worden (figuur 1.4 op pagina 5). Steeds was deze functie dan bij Maple bekend als
uitdrukking onder de naam f. Het is echter ook mogelijk om de functie f in te voeren als een
échte functie en niet als een uitdrukking. U hebt gezien hoe de standaardfuncties bij Maple
werken. Nu is de bedoeling dat we zelf functies maken die op dezelfde manier werken als
de standaardfuncties; dus met procedures waarin we aangeven wat er met het origineel moet
gebeuren om de functiewaarde te krijgen. We willen een functie f(x) = x2 + 1 definiëren,
waarmee we snel de functiewaarden kunnen uitrekenen, bijvoorbeeld f(x) of f(10).
Dit is alleen mogelijk als we de functie met behulp van de pijltjesnotatie invoeren en dat
vertegenwoordigt dan een procedure vergelijkbaar met de werking van echte functies. Als
f(10) opgevraagd wordt, dan weet het programma wat het moet doen namelijk de procedure
102 + 1. De pijltjesnotatie staat dus voor een procedure: wat er met het origineel moet
gebeuren om de functiewaarde te krijgen (zie figuur 2.11).

TIP: Het pijltje kunt u maken met behulp van het toetsenbord met het minteken en het
groterdanteken ->, maar het Expression-palet bevat deze uitdrukking ook (figuur 2.11).

Figuur 2.11 Een functie invoeren als procedure met de pijltjesnotatie eventueel ook te halen
uit het Expression-palet.

Toelichting: Definieer liever niet een functie met behulp van f(x):=... , want dan wordt
er iets heel anders bedoeld! Als u toch probeert een functie te definiëren met haakjes f(x)
en u hanteert 2D-Input, dan wordt er zelfs voor gewaarschuwd met een pop-up schermpje,
zoals in figuur 2.11 te zien is. Er wordt dan gevraagd wat precies de bedoeling is, namelijk:
of u werkelijk een functie wilt invoeren óf dat er middels een procedure iets onthouden moet
worden (proc() option remember....). Dat is ook goed te zien in het Variables-palet dat links
in de figuur correspondeert met de toekenningen die gedaan zijn. Immers met g(x):=x+3;
is beslist géén functie vastgelegd. Dat wil zeggen dat als x ingevuld wordt, dan weet het
programma wat het moet doen, maar als er iets anders ingevuld moet worden, dan weet het
programma het nı́et. Bijvoorbeeld g(y) zal opleveren g(y) en meer niet, terwijl het opvragen
van f(y) als resultaat y2 + 1 zal geven.

TIP: Als u de functie f hebt gedefinieerd met pijltjesnotatie als f:=x->x^2+1 en u geeft nog
een nieuwe toekenning bijvoorbeeld f(3):=20;, dan wordt de functie f daarmee niet teniet
gedaan. De functie f blijft in tact, maar het programma onthoudt in feite de ‘uitzondering’
voor f(3). De functiewaarde f(2) is dan bijvoorbeeld gewoon 5, de functiewaarde f(4) is
dus 17 maar f(3) is 20, want dat wordt ‘onthouden’. Als de grafiek van zo’n functie getekend
wordt, zou dat niet opvallen, omdat het maar om een enkel puntje gaat.
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TIP: Als u de functie f netjes met de pijltjesnotatie invoert, zoals in figuur 2.11 en vervolgens
een functiewaarde opvraagt, bijvoorbeeld f(7) of f(y), tik dan in de 2D-Input vooral geen
spatie! Immers een spatie wordt gezien als vermenigvuldiging bij 2D-Input. Het programma
zou dan als output kunnen geven 7 f respectievelijk f y en ziet het als vermenigvuldiging.
Bij de 1D-Input maken spaties niet uit.

Pijltjesnotatie bij een functie met parameters
Als er een parameter in het spel is, is het van belang om te weten welke de variabele is en
welke letter als parameter opgevat moet worden. Met de notatie f(x) = a x+3 bijvoorbeeld
wordt een functie van x bedoeld waarbij a een parameter is. Voer de functie dan in als échte
functie: f:=x->a*x+3; en vraag vervolgens naar f(5);.

> restart; f:=x->a*x+3;

f := x→ a x+ 3

> f(5);

5 a+ 3

Een uitdrukking omzetten naar een echte functie
Om van een functie die ingevoerd is als uitdrukking een echte functie (met pijltjesnotatie) te
maken, definieert u hem opnieuw met unapply en daarna is het mogelijk om deze functie
als echte functie te laten werken om bijvoorbeeld functiewaarden op te vragen:

> restart; g:=x^2-5*x;

g := x2 − 5x

> g:=unapply(g,x);

g := x→ x2 − 5x

> g(3);

−6
Er zijn dus twee methoden om een functie bij Maple te definiëren. Als uitdrukking met
een variabeletoekenning f:=... en met behulp van het functievoorschrift (pijltjesnotatie)
f:=x->.... Beide methoden hebben voordelen. In de rest van het boek komt het door
elkaar voor. Het hangt van de situatie af wat het handigst is.

TIP: Het commando unapply(uitdrukking,[variabelen]) werkt op een uitdrukking
waarin één of meer variabelen staan.

TIP: Het staat ook in het context-menu als u met de rechtermuisknop klikt op een uitdrukking
in de uitvoer, maar misschien niet als zodanig te herkennen. Bij Conversions kiest u voor
Operator (figuur 2.12) en vervolgens kunt u aangeven welke de variabelen zijn van de
te definiëren functie. Als er in de uitdrukking meer variabelen te herkennen zijn, past het
context-menu zich vanzelf aan en kunt u zelfs met behulp van een dialoogscherm nog
aangeven welke de variabelen van de functie zullen worden en welke niet.

TIP: Let wel op als u bijvoorbeeld de functie aanroept om er iets mee te gaan doen: een
grafiek tekenen met behulp van het commando plot bijvoorbeeld. Als de functie met
pijltjesnotatie gedefinieerd is, moet de functie aangeroepen wordt met de procedure f(x) en
niet met alleen de naam f . Dus om te plotten, typ dan plot(f(x),x=-5..5);. De functie
moet in het geval van plotten dan natuurlijk geen parameters bevatten.

TIP: Zie ook paragraaf 6.3.1 hoe het handig is om gebruik te maken van de invoer in
pijltjesnotatie bij differentiëren.
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Figuur 2.12 Van een uitdrukking een echte functie maken met
unapply(uitdrukking,[variabelen])

TIP: Een functie van twee (of meer) variabelen toekennen, gaat op dezelfde wijze en kan
ook uit het Expression-palet gehaald worden: f:=(a,b)->z. Let daarbij op de haakjes die
beslist om de variabelen moeten staan. De functiewaarde in punt (3, 5) krijgt u dan meteen
met f(3,5). Let daarbij wel op de volgorde én de haakjes!

2.2.9 Samengestelde functies

Een samengestelde functie is niets anders dan twee of meer functievoorschriften na elkaar
toegepast. Hiervoor kunnen reeds bekende functies gebruikt worden, maar ook zelfgedefi-
nieerde functies. Hieronder is een voorbeeld waarin de cosinusfunctie gecombineerd wordt
met de zelfgedefinieerde functie f := x → x2 + 4.
De samengestelde functie cos na f noteren we als cos ◦f en de 1D-input is dat (cos@f) met
haakjes eromheen.
Het @-teken is dus de operator voor het samenstellen van functies. Het gaat hierbij om echte
functies, met de pijltjesnotatie ingevoerd, of standaardfuncties die bij Maple bekend zijn. De
betekenis van cos ◦f is, dat eerst f wordt toegepast en vervolgens de cosinus wordt genomen
van het resultaat. Hier zou dat dan opleveren (cos ◦f)(x) = cos(x2 + 4). Andersom is ook
mogelijk en uitbreiding naar een ketting van meer functies is ook mogelijk.

> restart; f:=x->x^2+4; g:=x->sqrt(x+1);

f := x → x2 + 4
g := x →

√
x+ 1

> (cos@f)(x);

cos(x2 + 4)

> (f@cos)(x);

cos(x)2 + 4

> (f@cos@g)(x);

cos(
√
x+ 1)2 + 4

TIP: Let ook eens op de notatie in de uitvoer van cos(x)2 waar er dus bedoeld wordt
(cos(x))2 en waar wij zouden schrijven cos2(x). Als u in de 2D-Input cos2(x) invoert, wordt
dit door het programma wel goed begrepen. In de 1D-Input echter niet en moet u cos(x)^2

intikken.

TIP: Let op de haakjes om de functiecompositie heen!

TIP: Kijk ook eens in het Common Symbols-palet waar het teken ◦ (compfn) voor de
functiecompositie actief is als u 2D-formules invoert in de tekst of als het gaat om 2D-Input.
Zie figuur 2.13.
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Figuur 2.13 Het samenstellen van functies (f ◦ g)(x) betekent: eerst g toepassen en dan f .
In 1D-input is dat (f@g)(x)

2.3 Substitutie

Het is gemakkelijk om waarden in een functie te substitueren als u deze als echte functie
heeft ingevoerd met de pijltjesnotatie (zie paragraaf 2.2.8). Als u de functie ingevoert als
echte functie van bijvoorbeeld x en a met de pijltjesnotatie: f:=(x,a)-> ..., dan is het
gemakkelijk om over de functiewaarden te beschikken voor zekere waarden van x en a door
de functiewaarde gewoon op te vragen f(2,3). Let daarbij in ieder geval wel op de volgorde.
De betekenis is dat voor x = 2 en a = 3 de functiewaarde berekend wordt. Soms is het erg
handig om op deze manier te werken. In deze paragraaf komt een aantal voorbeelden aan de
orde om op verschillende manieren waarden in te vullen in uitdrukkingen.

TIP: Nog even op een rijtje:
Bij het invoeren van een uitdrukking is het handig om deze een naam te geven.
Maak onderscheid tussen een toekenning met := en een vergelijking met het =-teken. Een
toekenning ongedaan maken wordt uitgelegd in paragraaf 1.6.2.
Geef namen aan de entiteiten die u invoert en maak onderscheid tussen hoofdletters en kleine
letters.
Let op verschillen in 1D-Input en 2D-Input. De sterren in de invoer zijn nodig als u een
vermenigvuldiging bedoelt. Dit teken is beslist noodzakelijk in de 1D-Input; 3x wordt niet
opgevat als een vermenigvuldiging als u er geen ster tussen tikt in de invoer, maar in de 2D-
Input kunt u de ster weglaten en kunt u eventueel een spatie tikken voor vermenigvuldiging.
Beter is het gewoon ALTIJD een ster te tikken als u een vermenigvuldiging bedoelt.

2.3.1 Evaluatie van een formule met eval

De eerste mogelijkheid om waarden in te vullen in een uitdrukking is met het context-menu,
maar het kan ook met het Expression-palet, zodat u eventueel zelfs geheel syntax-vrij kunt
werken.
De structuur van dit commando is eval(formule,variabele=waarde). Dus eigenlijk
vertaald: evalueer de formule voor de volgende waarde van de variabele.

We willen bijvoorbeeld in de vergelijking x2− 8x+7 = 0 voor x de waarde 7 invullen. Hoe
dat gaat, staat in figuur 2.14:

Toelichting: In het context-menu, dat geactiveerd wordt met de rechtermuisknop als u met
de cursor op de uitvoer staat, kan gekozen worden voor Evaluate at a Point. Het is trouwens
écht een context-menu, want er verschijnen in dit menu allerlei commando’s die specifiek op
vergelijkingen betrekking hebben. Zie voor meer informatie over vergelijkingen in paragraaf
2.6. Maple herkent namelijk direct het object dat aangeklikt wordt, en geeft daarbij passende
context-menu’s. Op deze manier krijgen we een identieke vergelijking als het getal 7 wordt
ingevuld voor x. Dat wil zeggen dat de waarde x = 7 voldoet aan de gegeven vergelijking.
Het valt op dat in het automatisch gegenereerde commando in 1D-Input de waarde x = 7
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